summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbappconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbappconf')
-rw-r--r--x11-misc/bbappconf/Manifest1
-rw-r--r--x11-misc/bbappconf/bbappconf-0.0.2.ebuild32
-rw-r--r--x11-misc/bbappconf/files/bbappconf-0.0.2-asneeded.patch89
-rw-r--r--x11-misc/bbappconf/files/bbappconf-0.0.2-docs.patch14
-rw-r--r--x11-misc/bbappconf/files/bbappconf-0.0.2-fix-sigsegv.diff18
-rw-r--r--x11-misc/bbappconf/metadata.xml14
6 files changed, 168 insertions, 0 deletions
diff --git a/x11-misc/bbappconf/Manifest b/x11-misc/bbappconf/Manifest
new file mode 100644
index 000000000000..28ee91de3609
--- /dev/null
+++ b/x11-misc/bbappconf/Manifest
@@ -0,0 +1 @@
+DIST bbappconf-0.0.2.tar.gz 80107 SHA256 90f02de8f9b507e53232c77f179382d1734fa63c2978070c4582dea575434705 SHA512 910ebaff204b3bbed88296b077a50fd061e9dee74703991f8f43079aae736a65f98acafe8b437b6d3f7e021173a5f09a8bd98549b8a63d12718d8f2389284117 WHIRLPOOL 72bfbc597289aaada28c91041f1685a9faac605e3af0635a135f5e73e57f86955a7915366646dd386a4a98b96d18ceab50c70be6e2883a364ece2bc0b7968408
diff --git a/x11-misc/bbappconf/bbappconf-0.0.2.ebuild b/x11-misc/bbappconf/bbappconf-0.0.2.ebuild
new file mode 100644
index 000000000000..441d5b86c6ef
--- /dev/null
+++ b/x11-misc/bbappconf/bbappconf-0.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="utility that allows you to specify window properties in blackbox"
+HOMEPAGE="http://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc sparc x86 ~x86-fbsd"
+IUSE="debug"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO data/README.bbappconf )
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-sigsegv.diff \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-docs.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
diff --git a/x11-misc/bbappconf/files/bbappconf-0.0.2-asneeded.patch b/x11-misc/bbappconf/files/bbappconf-0.0.2-asneeded.patch
new file mode 100644
index 000000000000..1a2008218c69
--- /dev/null
+++ b/x11-misc/bbappconf/files/bbappconf-0.0.2-asneeded.patch
@@ -0,0 +1,89 @@
+Fixing build with --as-needed
+
+https://bugs.gentoo.org/show_bug.cgi?id=248548
+
+--- configure.in
++++ configure.in
+@@ -5,38 +5,25 @@
+
+ AC_PREFIX_DEFAULT(/usr/local)
+
+-
+-
+ AC_CHECK_PROGS(regex_cmd, sed)
+ if test x$regex_cmd = "x"; then
+ AC_MSG_ERROR([error. sed is required to build the default bbtoolsrc file.])
+ fi
+
+-
+-dnl get the debug values right
+-AC_DEFUN(AC_SET_DEBUG,
+-[
+- test "$CFLAGS" = "" && CFLAGS="-g -Wall -DDEBUG"
+- test "$CXXFLAGS" = "" && CXXFLAGS="-g -Wall -DDEBUG"
+- test "$LDFLAGS" = "" && LDFLAGS=""
+-])
+-
+-AC_DEFUN(AC_SET_NODEBUG,
+-[
+- test "$CFLAGS" = "" && CFLAGS="-O2 -Wall"
+- test "$CXXFLAGS" = "" && CXXFLAGS="-O2 -Wall"
+- test "$LDFLAGS" = "" && LDFLAGS="-s"
+-])
+-
+-
++dnl Check for debug
++DEBUG=""
++AC_MSG_CHECKING([whether to enable debug code])
+ AC_ARG_ENABLE(debug,[ --enable-debug create debugging code [default=no]],
+-[
+-if test $enableval = "no";
+- then AC_SET_NODEBUG
+- else AC_SET_DEBUG
+-fi
+-],
+-AC_SET_NODEBUG)
++ if test x$enableval = "xyes"; then
++ AC_MSG_RESULT([yes])
++ DEBUG="-DDEBUG"
++ else
++ AC_MSG_RESULT([no])
++ fi,
++ AC_MSG_RESULT([no])
++ DEBUG=""
++)
++AC_SUBST(DEBUG)
+
+ dnl Check for Interlacing
+ INTERLACE=""
+@@ -69,15 +56,8 @@
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+-
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+-
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++AC_CHECK_LIB(X11, XOpenDisplay,,AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- Makefile.am
++++ Makefile.am
+@@ -1,4 +1,4 @@
+-CPPFLAGS = @CPPFLAGS@ @INTERLACE@ \
++AM_CPPFLAGS = @DEBUG@ @INTERLACE@ \
+ -DGLOBAL_BB=\"$(datadir)/bbtools/bbappconf.bb\" \
+ -DGLOBAL_NOBB=\"$(datadir)/bbtools/bbappconf.nobb\"
+
+@@ -18,4 +18,4 @@
+ NETInterface.cc NETInterface.hh \
+ blackboxstyle.hh
+ EXTRA_DIST = BUGS TODO
+-bbappconf_LDADD = @X_LIBS@
++bbappconf_LDADD = @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@
diff --git a/x11-misc/bbappconf/files/bbappconf-0.0.2-docs.patch b/x11-misc/bbappconf/files/bbappconf-0.0.2-docs.patch
new file mode 100644
index 000000000000..b92e92faae73
--- /dev/null
+++ b/x11-misc/bbappconf/files/bbappconf-0.0.2-docs.patch
@@ -0,0 +1,14 @@
+Don't install README to /usr/share/${PN}
+
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -1,8 +1,7 @@
+ configdir = $(datadir)/bbtools
+
+ config_DATA = bbappconf.bb \
+- bbappconf.nobb \
+- README.bbappconf
++ bbappconf.nobb
+
+ EXTRA_DIST = $(config_DATA)
+
diff --git a/x11-misc/bbappconf/files/bbappconf-0.0.2-fix-sigsegv.diff b/x11-misc/bbappconf/files/bbappconf-0.0.2-fix-sigsegv.diff
new file mode 100644
index 000000000000..178677389faf
--- /dev/null
+++ b/x11-misc/bbappconf/files/bbappconf-0.0.2-fix-sigsegv.diff
@@ -0,0 +1,18 @@
+Files bbappconf-0.0.2.orig/.BaseDisplay.cc.swp and bbappconf-0.0.2/.BaseDisplay.cc.swp differ
+Files bbappconf-0.0.2.orig/.resource.cc.swp and bbappconf-0.0.2/.resource.cc.swp differ
+diff -urN bbappconf-0.0.2.orig/resource.cc bbappconf-0.0.2/resource.cc
+--- bbappconf-0.0.2.orig/resource.cc 2005-01-19 09:49:19.000000000 -0500
++++ bbappconf-0.0.2/resource.cc 2005-01-19 10:09:42.530236696 -0500
+@@ -19,10 +19,12 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdlib>
+ #include "resource.hh"
+ #include "blackboxstyle.hh"
+
+ Resource::Resource(ToolWindow *toolwindow): BaseResource(toolwindow) {
++ frame.font = NULL;
+ Load();
+ }
+
diff --git a/x11-misc/bbappconf/metadata.xml b/x11-misc/bbappconf/metadata.xml
new file mode 100644
index 000000000000..651c7b4f59f9
--- /dev/null
+++ b/x11-misc/bbappconf/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ bbappconf is a utility that allows you to specify window properties
+ in Blackbox.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>