summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-10 09:57:55 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-10 10:11:26 -0400
commit089218976cd46592373de0f9fd6ec617a992a1c6 (patch)
tree24540add9d9892d43e1f98c6b520958f78b0da89 /x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
parentx11-apps/xwininfo: Version bump to 1.1.6 (diff)
downloadgentoo-089218976cd46592373de0f9fd6ec617a992a1c6.tar.gz
gentoo-089218976cd46592373de0f9fd6ec617a992a1c6.tar.bz2
gentoo-089218976cd46592373de0f9fd6ec617a992a1c6.zip
x11-libs/xcb-util-errors: Add new package, version 1.0.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild')
-rw-r--r--x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild b/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
new file mode 100644
index 000000000000..042df044f2f6
--- /dev/null
+++ b/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+XORG_TARBALL_SUFFIX="xz"
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="Library that gives human readable names to XCB error, event, & request codes"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-errors"
+
+KEYWORDS="~amd64"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:="
+DEPEND="${RDEPEND}
+ x11-base/xcb-proto"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'x11-base/xcb-proto[${PYTHON_USEDEP}]')
+"
+
+python_check_deps() {
+ python_has_version "x11-base/xcb-proto[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}