summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-09-22 18:04:46 -0700
committerMatt Turner <mattst88@gentoo.org>2020-09-22 18:08:15 -0700
commit9c8bb32642e9abbf92c99db0a69409e860b6c23f (patch)
tree4d3b003c2f894f7c638612703b21542ecbfcc205 /x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild
parentmedia-libs/mesa: Version bump to 20.1.8 (diff)
downloadgentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.tar.gz
gentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.tar.bz2
gentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.zip
x11-drivers/xf86-video-vesa: Version bump to 2.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild
new file mode 100644
index 000000000000..95d712819800
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ >=x11-libs/libpciaccess-0.12.901"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}