summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-11 22:49:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-12 15:05:51 +0100
commit274d6506e47717e007c93157cbe9720feb627a40 (patch)
tree28980597516dd8c52722fe0702656f85ed600353 /www-misc/urlwatch/urlwatch-2.6.ebuild
parentdev-python/pushbullet-py: new package, v. 0.10.0, optional dep of urlwatch. (diff)
downloadgentoo-274d6506e47717e007c93157cbe9720feb627a40.tar.gz
gentoo-274d6506e47717e007c93157cbe9720feb627a40.tar.bz2
gentoo-274d6506e47717e007c93157cbe9720feb627a40.zip
www-misc/urlwatch: version bump to 2.6.
This version adds support for Pushbullet notifications thanks to the new package 'dev-python/pushbullet-py'. Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3437
Diffstat (limited to 'www-misc/urlwatch/urlwatch-2.6.ebuild')
-rw-r--r--www-misc/urlwatch/urlwatch-2.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-misc/urlwatch/urlwatch-2.6.ebuild b/www-misc/urlwatch/urlwatch-2.6.ebuild
new file mode 100644
index 000000000000..43074696abd7
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/ https://pypi.python.org/pypi/urlwatch"
+SRC_URI="https://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || ( www-client/lynx app-text/html2text )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ fi
+}