summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-15 03:42:46 +0100
committerSam James <sam@gentoo.org>2022-07-15 03:46:25 +0100
commitf00ee1d6094b4167c8bae304124bd1d575c2d4e7 (patch)
tree9f5666710b5c06cb6e5f62b32d2c7030498c9188 /www-client
parentwww-plugins/chrome-binary-plugins: automated update (105.0.5176.3_alpha) (diff)
downloadgentoo-f00ee1d6094b4167c8bae304124bd1d575c2d4e7.tar.gz
gentoo-f00ee1d6094b4167c8bae304124bd1d575c2d4e7.tar.bz2
gentoo-f00ee1d6094b4167c8bae304124bd1d575c2d4e7.zip
www-client/microsoft-edge: automated bump (103.0.1264.62)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-103.0.1264.62.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 802f9ffe9bb9..b0f352c7e17d 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_103.0.1264.37-1_amd64.deb 120800512 BLAKE2B 03abbc5da0b9e2cb5614ac74c7cbdd078600364715e81591f9939d3e077c98b16970fa2a09df6e8d1bbca376da980e49b0923e0674befd4b80592b16c26dc5d5 SHA512 f0d2ccd3a073d3b7219b0eb1bb03d4f606eae5dc17efcbe1ef3837db634f99a0b33f9a45e8e7bb2654e13d30f086a87840a3c1cdc2dc9e40e02fc91d225d84e5
+DIST microsoft-edge-stable_103.0.1264.62-1_amd64.deb 120908516 BLAKE2B 015121a28800c52c7f27a3e1776610bb21c3a58769d33fc4173232bec37bde2fccc54892df9d650f456cfe0068872f67406e012a29592df84b4993ff9e57282a SHA512 8c87f9248b00a1039c31adf576ae63238497a39d7058ed1731f54a89c4babc3f7c5a77fe288d353bcd5eb511aa245421641ea1ee26009e98c9ac622bd386e581
diff --git a/www-client/microsoft-edge/microsoft-edge-103.0.1264.62.ebuild b/www-client/microsoft-edge/microsoft-edge-103.0.1264.62.ebuild
new file mode 100644
index 000000000000..a8cc7e730ebf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-103.0.1264.62.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}