summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/surf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/Manifest1
-rw-r--r--www-client/surf/files/surf-0.6-gentoo.patch133
-rw-r--r--www-client/surf/files/surf-9999-gentoo.patch133
-rw-r--r--www-client/surf/metadata.xml10
-rw-r--r--www-client/surf/surf-0.6-r1.ebuild64
-rw-r--r--www-client/surf/surf-0.6-r2.ebuild68
-rw-r--r--www-client/surf/surf-9999.ebuild61
7 files changed, 470 insertions, 0 deletions
diff --git a/www-client/surf/Manifest b/www-client/surf/Manifest
new file mode 100644
index 000000000000..cea1d6f45af8
--- /dev/null
+++ b/www-client/surf/Manifest
@@ -0,0 +1 @@
+DIST surf-0.6.tar.gz 14781 SHA256 fdc1ccfaee5c4f008eeb8fe5f9200d3ad71296e8d7af52bdd6a771f111866805 SHA512 f3550535351e37296280d33d229998e1f00aa605d0dab4a58944cf213721e823a1cfd9134b7bca2a4d61e265122a30d5dc917a290163ed8af2b24cd75d41a100 WHIRLPOOL 2a163d450b47b4964ce3686d76bf6e3a747984f0e86f84e2dccfa9d3e885bc26adf0100cdef48ae19d91f34a2d14d6c4950d2a7db7d333612e2b1fc48b077f99
diff --git a/www-client/surf/files/surf-0.6-gentoo.patch b/www-client/surf/files/surf-0.6-gentoo.patch
new file mode 100644
index 000000000000..cda644baa84e
--- /dev/null
+++ b/www-client/surf/files/surf-0.6-gentoo.patch
@@ -0,0 +1,133 @@
+--- a/config.mk
++++ b/config.mk
+@@ -4,27 +4,27 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX = /usr
++MANPREFIX = $(PREFIX)/share/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = $(shell $(PKG_CONFIG) --cflags x11)
++X11LIB = $(shell $(PKG_CONFIG) --libs x11)
+
+-GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
+-GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
++GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
++GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
+
+ # includes and libs
+-INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
++INCS = -I. -I/usr/include $(X11INC) $(GTKINC)
++LIBS = $(X11LIB) $(GTKLIB)
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -g ${LIBS}
++CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_BSD_SOURCE
++CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)
++LDFLAGS += $(LIBS)
+
+ # Solaris
+-#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+-#LDFLAGS = ${LIBS}
++#CFLAGS = -fast $(INCS) -DVERSION=\"$(VERSION)\"
++#LDFLAGS = $(LIBS)
+
+ # compiler and linker
+-CC = cc
++CC ?= gcc
+--- a/Makefile
++++ b/Makefile
+@@ -4,58 +4,58 @@
+ include config.mk
+
+ SRC = surf.c
+-OBJ = ${SRC:.c=.o}
++OBJ = $(SRC:.c=.o)
+
+ all: options surf
+
+ options:
+ @echo surf build options:
+- @echo "CFLAGS = ${CFLAGS}"
+- @echo "LDFLAGS = ${LDFLAGS}"
+- @echo "CC = ${CC}"
++ @echo "CFLAGS = $(CFLAGS)"
++ @echo "LDFLAGS = $(LDFLAGS)"
++ @echo "CC = $(CC)"
+
+ .c.o:
+ @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ $(CC) -c $(CFLAGS) $<
+
+-${OBJ}: config.h config.mk
++$(OBJ): config.h config.mk
+
+ config.h:
+ @echo creating $@ from config.def.h
+- @cp config.def.h $@
++ cp config.def.h $@
+
+-surf: ${OBJ}
++surf: $(OBJ)
+ @echo CC -o $@
+- @${CC} -o $@ surf.o ${LDFLAGS}
++ $(CC) -o $@ surf.o $(LDFLAGS)
+
+ clean:
+ @echo cleaning
+- @rm -f surf ${OBJ} surf-${VERSION}.tar.gz
++ rm -f surf $(OBJ) surf-$(VERSION).tar.gz
+
+ dist: clean
+ @echo creating dist tarball
+- @mkdir -p surf-${VERSION}
+- @cp -R LICENSE Makefile config.mk config.def.h README \
++ mkdir -p surf-$(VERSION)
++ cp -R LICENSE Makefile config.mk config.def.h README \
+ surf-open.sh arg.h TODO.md surf.png \
+- surf.1 ${SRC} surf-${VERSION}
+- @tar -cf surf-${VERSION}.tar surf-${VERSION}
+- @gzip surf-${VERSION}.tar
+- @rm -rf surf-${VERSION}
++ surf.1 $(SRC) surf-$(VERSION)
++ tar -cf surf-$(VERSION).tar surf-$(VERSION)
++ gzip surf-$(VERSION).tar
++ rm -rf surf-$(VERSION)
+
+ install: all
+- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+- @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f surf ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/surf
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+- @sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo installing executable file to $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp -f surf $(DESTDIR)$(PREFIX)/bin
++ chmod 755 $(DESTDIR)$(PREFIX)/bin/surf
++ @echo installing manual page to $(DESTDIR)$(MANPREFIX)/man1
++ mkdir -p $(DESTDIR)$(MANPREFIX)/man1
++ sed "s/VERSION/$(VERSION)/g" < surf.1 > $(DESTDIR)$(MANPREFIX)/man1/surf.1
++ chmod 644 $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ uninstall:
+- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/surf
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo removing executable file from $(DESTDIR)$(PREFIX)/bin
++ rm -f $(DESTDIR)$(PREFIX)/bin/surf
++ @echo removing manual page from $(DESTDIR)$(MANPREFIX)/man1
++ rm -f $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ .PHONY: all options clean dist install uninstall
diff --git a/www-client/surf/files/surf-9999-gentoo.patch b/www-client/surf/files/surf-9999-gentoo.patch
new file mode 100644
index 000000000000..424b08d75cc3
--- /dev/null
+++ b/www-client/surf/files/surf-9999-gentoo.patch
@@ -0,0 +1,133 @@
+--- a/config.mk
++++ b/config.mk
+@@ -4,27 +4,27 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX = /usr
++MANPREFIX = $(PREFIX)/share/man
+
+-X11INC = /usr/X11R6/include
+-X11LIB = /usr/X11R6/lib
++X11INC = $(shell $(PKG_CONFIG) --cflags x11)
++X11LIB = $(shell $(PKG_CONFIG) --libs x11)
+
+-GTKINC = `pkg-config --cflags gtk+-2.0 webkit-1.0`
+-GTKLIB = `pkg-config --libs gtk+-2.0 webkit-1.0`
++GTKINC = $(shell $(PKG_CONFIG) --cflags gtk+-2.0 gthread-2.0 webkit-1.0)
++GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0 webkit-1.0)
+
+ # includes and libs
+-INCS = -I. -I/usr/include -I${X11INC} ${GTKINC}
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${GTKLIB} -lgthread-2.0
++INCS = -I. -I/usr/include $(X11INC) $(GTKINC)
++LIBS = $(X11LIB) $(GTKLIB)
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\" -D_DEFAULT_SOURCE
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -g ${LIBS}
++CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_DEFAULT_SOURCE
++CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)
++LDFLAGS += $(LIBS)
+
+ # Solaris
+-#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+-#LDFLAGS = ${LIBS}
++#CFLAGS = -fast $(INCS) -DVERSION=\"$(VERSION)\"
++#LDFLAGS = $(LIBS)
+
+ # compiler and linker
+-CC = cc
++CC ?= gcc
+--- a/Makefile
++++ b/Makefile
+@@ -4,58 +4,58 @@
+ include config.mk
+
+ SRC = surf.c
+-OBJ = ${SRC:.c=.o}
++OBJ = $(SRC:.c=.o)
+
+ all: options surf
+
+ options:
+ @echo surf build options:
+- @echo "CFLAGS = ${CFLAGS}"
+- @echo "LDFLAGS = ${LDFLAGS}"
+- @echo "CC = ${CC}"
++ @echo "CFLAGS = $(CFLAGS)"
++ @echo "LDFLAGS = $(LDFLAGS)"
++ @echo "CC = $(CC)"
+
+ .c.o:
+ @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ $(CC) -c $(CFLAGS) $<
+
+-${OBJ}: config.h config.mk
++$(OBJ): config.h config.mk
+
+ config.h:
+ @echo creating $@ from config.def.h
+- @cp config.def.h $@
++ cp config.def.h $@
+
+-surf: ${OBJ}
++surf: $(OBJ)
+ @echo CC -o $@
+- @${CC} -o $@ surf.o ${LDFLAGS}
++ $(CC) -o $@ surf.o $(LDFLAGS)
+
+ clean:
+ @echo cleaning
+- @rm -f surf ${OBJ} surf-${VERSION}.tar.gz
++ rm -f surf $(OBJ) surf-$(VERSION).tar.gz
+
+ dist: clean
+ @echo creating dist tarball
+- @mkdir -p surf-${VERSION}
+- @cp -R LICENSE Makefile config.mk config.def.h README \
++ mkdir -p surf-$(VERSION)
++ cp -R LICENSE Makefile config.mk config.def.h README \
+ surf-open.sh arg.h TODO.md surf.png \
+- surf.1 ${SRC} surf-${VERSION}
+- @tar -cf surf-${VERSION}.tar surf-${VERSION}
+- @gzip surf-${VERSION}.tar
+- @rm -rf surf-${VERSION}
++ surf.1 $(SRC) surf-$(VERSION)
++ tar -cf surf-$(VERSION).tar surf-$(VERSION)
++ gzip surf-$(VERSION).tar
++ rm -rf surf-$(VERSION)
+
+ install: all
+- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+- @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f surf ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/surf
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+- @sed "s/VERSION/${VERSION}/g" < surf.1 > ${DESTDIR}${MANPREFIX}/man1/surf.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo installing executable file to $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp -f surf $(DESTDIR)$(PREFIX)/bin
++ chmod 755 $(DESTDIR)$(PREFIX)/bin/surf
++ @echo installing manual page to $(DESTDIR)$(MANPREFIX)/man1
++ mkdir -p $(DESTDIR)$(MANPREFIX)/man1
++ sed "s/VERSION/$(VERSION)/g" < surf.1 > $(DESTDIR)$(MANPREFIX)/man1/surf.1
++ chmod 644 $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ uninstall:
+- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/surf
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/surf.1
++ @echo removing executable file from $(DESTDIR)$(PREFIX)/bin
++ rm -f $(DESTDIR)$(PREFIX)/bin/surf
++ @echo removing manual page from $(DESTDIR)$(MANPREFIX)/man1
++ rm -f $(DESTDIR)$(MANPREFIX)/man1/surf.1
+
+ .PHONY: all options clean dist install uninstall
diff --git a/www-client/surf/metadata.xml b/www-client/surf/metadata.xml
new file mode 100644
index 000000000000..a30445e0d016
--- /dev/null
+++ b/www-client/surf/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='savedconfig'>Without a saved config.h, this package depends on <pkg>net-misc/curl</pkg> and <pkg>x11-terms/st</pkg> for a default download mechanism</flag>
+</use>
+</pkgmetadata>
diff --git a/www-client/surf/surf-0.6-r1.ebuild b/www-client/surf/surf-0.6-r1.ebuild
new file mode 100644
index 000000000000..d5f45712de12
--- /dev/null
+++ b/www-client/surf/surf-0.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+"
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch_user
+ restore_config config.h
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ save_config config.h
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+ fi
+}
diff --git a/www-client/surf/surf-0.6-r2.ebuild b/www-client/surf/surf-0.6-r2.ebuild
new file mode 100644
index 000000000000..327f7d878b68
--- /dev/null
+++ b/www-client/surf/surf-0.6-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch_user
+ restore_config config.h
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ save_config config.h
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+ fi
+}
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
new file mode 100644
index 000000000000..97df92ea65b9
--- /dev/null
+++ b/www-client/surf/surf-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils git-2 savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+EGIT_REPO_URI="git://git.suckless.org/surf"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+COMMON_DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch_user
+ restore_config config.h
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ save_config config.h
+}