summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-05-12 12:21:48 -0400
committerCraig Andrews <candrews@gentoo.org>2024-05-12 12:22:01 -0400
commit525d30957f7dd5bfb95a106066d2ccb262f9d7dc (patch)
tree92146bd790e107be9e28122cd38cea700c953f54 /www-apps
parentgames-fps/ut2004: Fix patch URL (diff)
downloadgentoo-525d30957f7dd5bfb95a106066d2ccb262f9d7dc.tar.gz
gentoo-525d30957f7dd5bfb95a106066d2ccb262f9d7dc.tar.bz2
gentoo-525d30957f7dd5bfb95a106066d2ccb262f9d7dc.zip
www-apps/jellyfin-bin: add 10.9.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jellyfin-bin/Manifest2
-rw-r--r--www-apps/jellyfin-bin/jellyfin-bin-10.9.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/www-apps/jellyfin-bin/Manifest b/www-apps/jellyfin-bin/Manifest
index ed01436f4de1..c6dc08c03c56 100644
--- a/www-apps/jellyfin-bin/Manifest
+++ b/www-apps/jellyfin-bin/Manifest
@@ -1,2 +1,4 @@
DIST jellyfin_10.8.13_amd64.tar.gz 99122530 BLAKE2B 38c5cdb8f0cb5b20f12d6e682277a87d5bf00d083ce346a97d43e77f69dbe99ab2a7f03cc88c94ce9fee365c79d932ce4e5c62c2a820f3b007f32b5b95b5b101 SHA512 a7c468ec3500ebe5b4eb18d2dfb75f4c41c237e9e61577eab431021b6c7e173375519ba9f163b1c0fc1f7603771067c60b085c15de09b7db8276e33bffe2aa36
DIST jellyfin_10.8.13_arm64.tar.gz 96059100 BLAKE2B 7b0efda60fa8cd93b0f4dc769d032840da6b2e139fa1a6496fb20270e9bbff7eff6adfdac73fe4a2a9529eb258f7943c50bbb57e4886cc6bf40951fc6b760414 SHA512 b964f1850f2e60e853a6620e957bd67922c0fc823813c193108350cbb7c0d30b4afec80bddb36db4fdc45078f67e1f3398c134fe7ac4a8cd7f38b9bbbbcc3080
+DIST jellyfin_10.9.0-amd64.tar.xz 79564752 BLAKE2B 934e7618a088480b3bdea84a6607de55bdc936af3b481a90ac01daf9ac9de318e8b6d4f4cf49f2a2ca32aea0ba9e1a2a132cbc386a372c61ffb0e47965245bdb SHA512 fdf993c3dcbfb1ea8452e07c1ed2c68e4100f48a01d0cae0789ec01194dd4d5c4281eee337b574cac88a588d93ea01ff87e7a0bdeee0041fcb4b7b4a32eba452
+DIST jellyfin_10.9.0-arm64.tar.xz 75960244 BLAKE2B 41a5e24cf0a6db05813259fe1c26130597673b6d2156df4e2236e87486418e2296848518c9d34132ce6cc1ada23a020ef7612aead50053cee8f1216b5fc0457d SHA512 7e7cbed120287f5e5be3b8c770bff99b57f40bbff619e754e06a110f67ed286043263d5fc2c574a9dcae222fed13bc31780235a505a0a70f2f88344f88f7d20b
diff --git a/www-apps/jellyfin-bin/jellyfin-bin-10.9.0.ebuild b/www-apps/jellyfin-bin/jellyfin-bin-10.9.0.ebuild
new file mode 100644
index 000000000000..9d3d4b9305fe
--- /dev/null
+++ b/www-apps/jellyfin-bin/jellyfin-bin-10.9.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pax-utils systemd tmpfiles
+
+DESCRIPTION="Jellyfin puts you in control of managing and streaming your media"
+HOMEPAGE="https://jellyfin.readthedocs.io/en/latest/
+ https://github.com/jellyfin/jellyfin/"
+
+SRC_URI="
+ arm64? (
+ https://repo.jellyfin.org/files/server/linux/stable/v${PV}/arm64/jellyfin_${PV}-arm64.tar.xz
+ )
+ amd64? (
+ https://repo.jellyfin.org/files/server/linux/stable/v${PV}/amd64/jellyfin_${PV}-amd64.tar.xz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+RESTRICT="mirror test"
+REQUIRED_USE="elibc_glibc"
+
+DEPEND="acct-user/jellyfin
+ media-libs/fontconfig
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-libs/icu
+ media-video/ffmpeg[vpx,x264]"
+BDEPEND="acct-user/jellyfin"
+
+INST_DIR="/opt/jellyfin"
+QA_PREBUILT="${INST_DIR#/}/*.so ${INST_DIR#/}/jellyfin ${INST_DIR#/}/createdump"
+
+src_unpack() {
+ unpack ${A}
+ mv jellyfin ${P} || die
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/jellyfin/jellyfin/issues/7471
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ keepdir /var/log/jellyfin
+ fowners jellyfin:jellyfin /var/log/jellyfin
+ keepdir /etc/jellyfin
+ fowners jellyfin:jellyfin /etc/jellyfin
+ insinto ${INST_DIR}
+ dodir ${INST_DIR}
+ doins -r "${S}"/*
+ newtmpfiles - jellyfin.conf <<<"d /var/cache/jellyfin 0775 jellyfin jellyfin -"
+ chmod 755 "${D}${INST_DIR}/jellyfin"
+ newinitd "${FILESDIR}/jellyfin.init-r1" "jellyfin"
+ newconfd "${FILESDIR}"/jellyfin.confd "jellyfin"
+ systemd_dounit "${FILESDIR}/jellyfin.service"
+ pax-mark -m "${ED}${INST_DIR}/jellyfin"
+}
+
+pkg_postinst() {
+ tmpfiles_process jellyfin.conf
+}