summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-12 18:42:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-12 18:48:03 +0200
commit20f8702b523411504640360cbdec58983c338c4e (patch)
tree60754bfb4842d89606905a49983917239c417ecf /www-apps/selfoss/selfoss-2.19.ebuild
parentapp-containers/lxd: fix ebuild to support secure boot with VMs (diff)
downloadgentoo-20f8702b523411504640360cbdec58983c338c4e.tar.gz
gentoo-20f8702b523411504640360cbdec58983c338c4e.tar.bz2
gentoo-20f8702b523411504640360cbdec58983c338c4e.zip
www-apps/selfoss: bump to 2.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'www-apps/selfoss/selfoss-2.19.ebuild')
-rw-r--r--www-apps/selfoss/selfoss-2.19.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/selfoss/selfoss-2.19.ebuild b/www-apps/selfoss/selfoss-2.19.ebuild
new file mode 100644
index 000000000000..a3a420945e26
--- /dev/null
+++ b/www-apps/selfoss/selfoss-2.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 webapp
+
+DESCRIPTION="The multipurpose rss reader, live stream, mashup, aggregation web application"
+HOMEPAGE="https://selfoss.aditu.de/"
+SRC_URI="https://github.com/SSilence/${PN}/releases/download/${PV}/${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="
+ >=dev-lang/php-5.6.0[curl,gd]
+ <dev-lang/php-8
+ virtual/httpd-php
+ || (
+ dev-db/mysql
+ dev-db/postgresql
+ dev-db/sqlite
+ )
+"
+
+DOC_CONTENTS="Default selfoss config is installed as defaults.ini,
+copy that config to config.ini and customize as you wish."
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/public
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}