summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_vdbh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_vdbh')
-rw-r--r--www-apache/mod_vdbh/Manifest1
-rw-r--r--www-apache/mod_vdbh/files/21_mod_vdbh.conf18
-rw-r--r--www-apache/mod_vdbh/metadata.xml5
-rw-r--r--www-apache/mod_vdbh/mod_vdbh-1.0.3-r1.ebuild29
4 files changed, 53 insertions, 0 deletions
diff --git a/www-apache/mod_vdbh/Manifest b/www-apache/mod_vdbh/Manifest
new file mode 100644
index 000000000000..5aa91227cd9f
--- /dev/null
+++ b/www-apache/mod_vdbh/Manifest
@@ -0,0 +1 @@
+DIST mod_vdbh-1.0.3.tar.gz 8053 SHA256 ff034dc4a77d82085dad1b867af8d913034c476d7cc2bf3472e6ae38cef40225
diff --git a/www-apache/mod_vdbh/files/21_mod_vdbh.conf b/www-apache/mod_vdbh/files/21_mod_vdbh.conf
new file mode 100644
index 000000000000..337e07bbecdb
--- /dev/null
+++ b/www-apache/mod_vdbh/files/21_mod_vdbh.conf
@@ -0,0 +1,18 @@
+<IfDefine VDBH>
+LoadModule vdbh_module modules/mod_vdbh.so
+
+#NameVirtualHost 206.9.161.29
+#<VirtualHost 206.9.161.29>
+# vdbh On
+# vdbh_CLIENT_COMPRESS On
+# vdbh_MySQL_Database virtual_hosts
+# vdbh_MySQL_Table virtual_hosts
+# vdbh_MySQL_Host_Field server
+# vdbh_MySQL_Path_Field path
+# vdbh_MySQL_Environment_Field environment_variable
+# vdbh_Default_Host julia.fractal.net
+# vdbh_Declines .htpasswd *.txt
+#</VirtualHost>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_vdbh/metadata.xml b/www-apache/mod_vdbh/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_vdbh/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_vdbh/mod_vdbh-1.0.3-r1.ebuild b/www-apache/mod_vdbh/mod_vdbh-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..538cfbfc19cb
--- /dev/null
+++ b/www-apache/mod_vdbh/mod_vdbh-1.0.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+KEYWORDS="ppc x86"
+
+DESCRIPTION="An Apache2 module for mass virtual hosting using a MySQL database"
+HOMEPAGE="http://www.synthemesc.com/mod_vdbh/"
+SRC_URI="http://www.synthemesc.com/downloads/${PN}/${P}.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+DEPEND="virtual/mysql
+ >=sys-libs/zlib-1.1.4"
+RDEPEND="${DEPEND}"
+
+APXS2_ARGS="-DHAVE_STDDEF_H -I/usr/include/mysql -Wl,-lmysqlclient -c ${PN}.c"
+
+APACHE2_MOD_CONF="21_mod_vdbh"
+APACHE2_MOD_DEFINE="VDBH"
+
+DOCFILES="AUTHORS README"
+
+need_apache2