summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_dnssd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_dnssd')
-rw-r--r--www-apache/mod_dnssd/Manifest1
-rw-r--r--www-apache/mod_dnssd/files/80_mod_dnssd.conf6
-rw-r--r--www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch24
-rw-r--r--www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch22
-rw-r--r--www-apache/mod_dnssd/metadata.xml5
-rw-r--r--www-apache/mod_dnssd/mod_dnssd-0.6-r1.ebuild40
6 files changed, 98 insertions, 0 deletions
diff --git a/www-apache/mod_dnssd/Manifest b/www-apache/mod_dnssd/Manifest
new file mode 100644
index 000000000000..a91b572666e9
--- /dev/null
+++ b/www-apache/mod_dnssd/Manifest
@@ -0,0 +1 @@
+DIST mod_dnssd-0.6.tar.gz 86417 SHA256 2cd171d76eba398f03c1d5bcc468a1756f4801cd8ed5bd065086e4374997c5aa SHA512 c3eacd2065f996ace76496b828a5be4b735225782c88ed0fba00c37ffed91af7c81cef755556968880e11e05fbaf65a4326728cb82abcad03ccaf925be1f29d3 WHIRLPOOL aa27272b8e35fcc492e7265171ce720f9cefc157fdb9f4997474f669e97d168ce851f6351c8857dd8bf01d3e0ea2c87085de1aa2ddb114317d0649b84a2717ba
diff --git a/www-apache/mod_dnssd/files/80_mod_dnssd.conf b/www-apache/mod_dnssd/files/80_mod_dnssd.conf
new file mode 100644
index 000000000000..1c67f7e86efc
--- /dev/null
+++ b/www-apache/mod_dnssd/files/80_mod_dnssd.conf
@@ -0,0 +1,6 @@
+<IfDefine DNSSD>
+LoadModule dnssd_module modules/mod_dnssd.so
+DNSSDEnable on
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch b/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch
new file mode 100644
index 000000000000..6eb505810405
--- /dev/null
+++ b/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch
@@ -0,0 +1,24 @@
+--- mod_dnssd-0.6/src/mod_dnssd.c.httpd24
++++ mod_dnssd-0.6/src/mod_dnssd.c
+@@ -26,6 +26,9 @@
+ #include <unixd.h>
+ #include <apr_signal.h>
+ #include <mpm_common.h>
++#if AP_MODULE_MAGIC_AT_LEAST(20090130,0)
++#include <mod_unixd.h>
++#endif
+
+ #include <unistd.h>
+
+@@ -576,7 +579,11 @@ static void child_process(apr_pool_t *p,
+
+ ap_assert(d);
+
++#if AP_MODULE_MAGIC_AT_LEAST(20090130,0)
++ ap_unixd_setup_child();
++#else
+ unixd_setup_child();
++#endif
+
+ if (pipe(sigterm_pipe_fds) < 0) {
+ ap_log_error(APLOG_MARK, APLOG_ERR, 0, r.main_server, "pipe() failed: %s", strerror(errno));
diff --git a/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
new file mode 100644
index 000000000000..699f2301f442
--- /dev/null
+++ b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
@@ -0,0 +1,22 @@
+---
+ Respect LDFLAGS and properly use LIBS to avoid missing symbols at runtime.
+
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -16,13 +16,14 @@
+
+ APXS=@APXS@
+ APACHECTL=@APACHECTL@
+-LIBS=-Wl,"@LIBS@" @AVAHI_LIBS@
++LIBS="@LIBS@" @AVAHI_LIBS@
+ CFLAGS=-Wc,"@CFLAGS@" @AVAHI_CFLAGS@
++APXS_LDFLAGS=`for ldflag in $(LDFLAGS); do echo -Wl,$$ldflag; done`
+
+ all: mod_dnssd.la
+
+ mod_dnssd.la: @srcdir@/mod_dnssd.c
+- $(APXS) -c $(CFLAGS) $(LIBS) @srcdir@/mod_dnssd.c
++ $(APXS) -c $(CFLAGS) $(APXS_LDFLAGS) @srcdir@/mod_dnssd.c $(LIBS)
+
+ install: all
+ $(APXS) -i -a mod_dnssd.la
diff --git a/www-apache/mod_dnssd/metadata.xml b/www-apache/mod_dnssd/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_dnssd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_dnssd/mod_dnssd-0.6-r1.ebuild b/www-apache/mod_dnssd/mod_dnssd-0.6-r1.ebuild
new file mode 100644
index 000000000000..9caa769e8055
--- /dev/null
+++ b/www-apache/mod_dnssd/mod_dnssd-0.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module eutils
+
+DESCRIPTION="mod_dnssd is an Apache module which adds Zeroconf support via DNS-SD using Avahi"
+HOMEPAGE="http://0pointer.de/lennart/projects/mod_dnssd/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+DEPEND="net-dns/avahi[dbus]"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="80_${PN}"
+APACHE2_MOD_DEFINE="DNSSD"
+
+need_apache2
+
+src_prepare() {
+ # Respect LDFLAGS and use LIBS properly.
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ # Fedora patch for apache 2.4
+ epatch "${FILESDIR}/${P}-httpd24.patch"
+}
+
+src_configure() {
+ econf --with-apxs=${APXS} --disable-lynx
+}
+
+# Do not use inherited src_compile since it doesn't do what we want
+src_compile() {
+ emake
+}