summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:19:18 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:19:18 -0500
commitf63c8955c91f699f8484612cf33ae4f789c96a77 (patch)
tree960de5a7015dfa0ce8a41539f8c9b5ac8509c005 /virtual/libelf
parentprofiles: mask future >virtual/libelf-2 on musl and uclibc-ng (diff)
downloadgentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.tar.gz
gentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.tar.bz2
gentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.zip
virtual/libelf: split the virtual in two for different sonames, bug #643802
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'virtual/libelf')
-rw-r--r--virtual/libelf/libelf-0.ebuild12
-rw-r--r--virtual/libelf/libelf-2.ebuild12
-rw-r--r--virtual/libelf/libelf-3.ebuild (renamed from virtual/libelf/libelf-1.ebuild)5
3 files changed, 14 insertions, 15 deletions
diff --git a/virtual/libelf/libelf-0.ebuild b/virtual/libelf/libelf-0.ebuild
deleted file mode 100644
index 0b8e5336de81..000000000000
--- a/virtual/libelf/libelf-0.ebuild
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib-build
-
-DESCRIPTION="Virtual for libelf.so.0 provider (dev-libs/libelf)"
-SLOT="0/0"
-KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND=">=dev-libs/libelf-0.8.13-r2:0/0[${MULTILIB_USEDEP}]"
diff --git a/virtual/libelf/libelf-2.ebuild b/virtual/libelf/libelf-2.ebuild
new file mode 100644
index 000000000000..7f26e79291aa
--- /dev/null
+++ b/virtual/libelf/libelf-2.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for libelf.so.0 provider dev-libs/libelf"
+SLOT="0/0"
+KEYWORDS="alpha amd64 arm arm64 hppa m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/libelf-0.8.13-r2:0/0[${MULTILIB_USEDEP}]"
diff --git a/virtual/libelf/libelf-1.ebuild b/virtual/libelf/libelf-3.ebuild
index b2acd4bb7121..82c100cbdb56 100644
--- a/virtual/libelf/libelf-1.ebuild
+++ b/virtual/libelf/libelf-3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit multilib-build
-DESCRIPTION="Virtual for libelf.so.1 provider (dev-libs/elfutils)"
+DESCRIPTION="Virtual for libelf.so.1 provider dev-libs/elfutils"
SLOT="0/1"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
@@ -13,5 +13,4 @@ RDEPEND="
|| (
>=dev-libs/elfutils-0.155-r1:0/0[${MULTILIB_USEDEP}]
>=sys-freebsd/freebsd-lib-9.2_rc1[${MULTILIB_USEDEP}]
- >=dev-libs/libelf-0.8.13-r2:0/0[${MULTILIB_USEDEP}]
)"