summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-18 12:28:02 +0000
committerSam James <sam@gentoo.org>2024-11-18 12:28:12 +0000
commit78143eec123c0601b77631d989eba1ff030322fc (patch)
tree83d909fce2d18e3a418d6ff9912d6a69acf85951 /sys-process
parentapp-emulation/dxvk: add 2.5.1 (diff)
downloadgentoo-78143eec123c0601b77631d989eba1ff030322fc.tar.gz
gentoo-78143eec123c0601b77631d989eba1ff030322fc.tar.bz2
gentoo-78143eec123c0601b77631d989eba1ff030322fc.zip
sys-process/lsof: add 4.99.4
Closes: https://bugs.gentoo.org/943694 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/Manifest1
-rw-r--r--sys-process/lsof/lsof-4.99.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index 581bff9bb7c0..5bfb74baf179 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1,3 +1,4 @@
DIST lsof-4.98.0.tar.gz 734232 BLAKE2B 2f4ba4d179e8061e5bcff7dda4a0981616530bd5577fc73904e2699e6e982efee9e4270d3f2d3c68751d73cb98bfed0fd49d4c6bd967d15b4e06dcb72494d024 SHA512 6fde12497ce9cbba698be624b45e8392d551626c3e46b50ec23e661b322438ef7162dbac0d06829d56f074c7d934fa1ca98aa50ee1487125c93bebfe8eb2a2e8
DIST lsof-4.99.0.tar.gz 1127302 BLAKE2B 257f84e01b9530ab3a6c637c13c8e84c2562fa3ecd9048f93e2816bbed36ffd529311bc1424a41cde72383642decbd6f44e680bfdd2594bbae5908b07c466165 SHA512 6fe3039f1167fb3023a7f358dda2b4ea6eace1e50a97d0168af494217581eef73cc1742f544d2fb9f85ded8370c86e63d48104da899396de7b3007997a201825
DIST lsof-4.99.3.tar.gz 1131470 BLAKE2B f2f298d8fe3f03b192984a31bd6b368e08c3ae5b8776625df413b94a0db59258e8aadb8ab4b94b9a3a54803fab463c1b920b524ee0ff512c8cda4b88e89b4c50 SHA512 83f62f62fa273becfdded4e553d398bafebf0186c7f8ac86a800dabf63ef0614c3c546b6dcd6d13f30c97ab33088a82e1e6b66cc8ed61f700c54487cab19d009
+DIST lsof-4.99.4.tar.gz 1128285 BLAKE2B aa8e062f782f3e94688e725f963cc4a907abd49e1b78813ea3639afc284efb0946efd7f14f918f8792e253fb7bfceb6c3d258b84660d2af015a218d7cba16eb7 SHA512 5b04e2d8f26e6f76bcdb3e1282fbe71bb1b9379c76ffd88b05731920d5175595b0d4dbfd41a7ace1bfb4d21fcc7ebc641372af76c24ccb01bc3f5d7149ea4fa3
diff --git a/sys-process/lsof/lsof-4.99.4.ebuild b/sys-process/lsof/lsof-4.99.4.ebuild
new file mode 100644
index 000000000000..8c18e3255daf
--- /dev/null
+++ b/sys-process/lsof/lsof-4.99.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rpc selinux"
+
+RDEPEND="
+ rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/groff
+ rpc? ( virtual/pkgconfig )
+"
+
+# Needs fixing first for sandbox
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with rpc libtirpc)
+ $(use_with selinux)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ fi
+}