summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/criu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/criu/files')
-rw-r--r--sys-process/criu/files/criu-1.3.1-flags.patch55
-rw-r--r--sys-process/criu/files/criu-1.3.1-makefile.patch20
-rw-r--r--sys-process/criu/files/criu-1.5-automagic-libbsd.patch29
-rw-r--r--sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch12
4 files changed, 116 insertions, 0 deletions
diff --git a/sys-process/criu/files/criu-1.3.1-flags.patch b/sys-process/criu/files/criu-1.3.1-flags.patch
new file mode 100644
index 000000000000..84f503770557
--- /dev/null
+++ b/sys-process/criu/files/criu-1.3.1-flags.patch
@@ -0,0 +1,55 @@
+--- criu-1.3.1/Makefile
++++ criu-1.3.1/Makefile
+@@ -102,9 +102,6 @@
+
+ ifeq ($(DEBUG),1)
+ DEFINES += -DCR_DEBUG
+- CFLAGS += -O0 -ggdb3
+-else
+- CFLAGS += -O2
+ endif
+
+ ifeq ($(GMON),1)
+--- criu-1.3.1/test/zdtm/lib/Makefile
++++ criu-1.3.1/test/zdtm/lib/Makefile
+@@ -1,6 +1,6 @@
+ include ../Makefile.inc
+
+-CFLAGS = -g -O2 -Wall -Werror -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
++CFLAGS = -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
+ CFLAGS += $(USERCFLAGS)
+
+ LIBDIR = .
+--- criu-1.3.1/test/zdtm/live/static/Makefile
++++ criu-1.3.1/test/zdtm/live/static/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
++CFLAGS = -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
+--- criu-1.3.1/test/zdtm/live/streaming/Makefile
++++ criu-1.3.1/test/zdtm/live/streaming/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror -fno-strict-aliasing
++CFLAGS = -Wall -fno-strict-aliasing
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
+--- criu-1.3.1/test/zdtm/live/transition/Makefile
++++ criu-1.3.1/test/zdtm/live/transition/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror
++CFLAGS = -Wall
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
diff --git a/sys-process/criu/files/criu-1.3.1-makefile.patch b/sys-process/criu/files/criu-1.3.1-makefile.patch
new file mode 100644
index 000000000000..50781c192aa8
--- /dev/null
+++ b/sys-process/criu/files/criu-1.3.1-makefile.patch
@@ -0,0 +1,20 @@
+--- criu-1.3.1/Makefile.inc
++++ criu-1.3.1/Makefile.inc
+@@ -15,15 +15,9 @@
+ SBINDIR := $(PREFIX)/sbin
+ MANDIR := $(PREFIX)/share/man
+ SYSTEMDUNITDIR := $(PREFIX)/lib/systemd/system/
+-LOGROTATEDIR := $(PREFIX)/etc/logrotate.d/
++LOGROTATEDIR := $(SYSCONFDIR)/etc/logrotate.d/
+ LIBDIR := $(PREFIX)/lib
+-# For recent Debian/Ubuntu with multiarch support
+-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture \
+- -qDEB_HOST_MULTIARCH 2>/dev/null)
+-ifneq "$(DEB_HOST_MULTIARCH)" ""
+-LIBDIR := $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
+-# For most other systems
+-else ifeq "$(shell uname -m)" "x86_64"
++ifeq "$(shell uname -m)" "x86_64"
+ LIBDIR := $(PREFIX)/lib64
+ endif
+
diff --git a/sys-process/criu/files/criu-1.5-automagic-libbsd.patch b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
new file mode 100644
index 000000000000..8f5e4b4e02d0
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
@@ -0,0 +1,29 @@
+Control libbsd dependency via SETPROCTITLE definition.
+
+--- criu-1.5/Makefile.config
++++ criu-1.5/Makefile.config
+@@ -3,10 +3,12 @@
+
+ CONFIG := include/config.h
+
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(LIBBSD_DEV_TEST),-lbsd),y)
+ LIBS += -lbsd
+ DEFINES += -DCONFIG_HAS_LIBBSD
+ endif
++endif
+
+ $(CONFIG): scripts/utilities.mak scripts/feature-tests.mak include/config-base.h
+ $(E) " GEN " $@
+@@ -33,9 +35,11 @@
+ ifeq ($(VDSO),y)
+ $(Q) @echo '#define CONFIG_VDSO' >> $@
+ endif
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(SETPROCTITLE_INIT_TEST),-lbsd),y)
+ $(Q) @echo '#define CONFIG_HAS_SETPROCTITLE_INIT' >> $@
+ endif
++endif
+ $(Q) @echo '#endif /* __CR_CONFIG_H__ */' >> $@
+
+ config: $(CONFIG)
diff --git a/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
new file mode 100644
index 000000000000..497838132a24
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
@@ -0,0 +1,12 @@
+diff --git a/arch/aarch64/include/asm/types.h b/arch/aarch64/include/asm/types.h
+index 8dd336e..6657279 100644
+--- a/arch/aarch64/include/asm/types.h
++++ b/arch/aarch64/include/asm/types.h
+@@ -3,6 +3,7 @@
+
+ #include <stdbool.h>
+ #include <signal.h>
++#include <asm/ptrace.h>
+ #include "protobuf/core.pb-c.h"
+
+ #include "asm-generic/page.h"