summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-19 10:06:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-19 10:36:02 +0100
commit1ea5acde52551910184e0206ccea82056dd6aa7d (patch)
treee9ac393735fb0b2e96c339dca2d0d0006311a281 /sys-libs/libseccomp
parentdev-libs/libksba: Bump to version 1.5.0 (diff)
downloadgentoo-1ea5acde52551910184e0206ccea82056dd6aa7d.tar.gz
gentoo-1ea5acde52551910184e0206ccea82056dd6aa7d.tar.bz2
gentoo-1ea5acde52551910184e0206ccea82056dd6aa7d.zip
sys-libs/libseccomp: Bump to version 2.5.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/Manifest1
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/Manifest b/sys-libs/libseccomp/Manifest
index 87aea1370f33..ddb87bd168cd 100644
--- a/sys-libs/libseccomp/Manifest
+++ b/sys-libs/libseccomp/Manifest
@@ -1,3 +1,4 @@
DIST libseccomp-2.4.3.tar.gz 598147 BLAKE2B 272c9f1ca7e4059790f633a79cae8612831aa483d28630fb85b31dc2be0192907a8897819d835b61324e0b3fb0d77b8781e2a85e9750ef8d7974d8680b8cdea3 SHA512 7b7af2e98493243ffe1934fefff5723b24ae9b9bdc4bf039343ee8456c15acb0ea34e81ec292a41143848272aeca794ef92ad38fc3f42c77465170cb540479ef
DIST libseccomp-2.4.4.tar.gz 604420 BLAKE2B 04a2e22996d94f2525c1f4a890f325e7c75abb7ac84928a1ffde5e4cc569ef6355fcda8415e0c9937139e187f458602714cfd042008de74637c7bf30e9bd58e2 SHA512 53e5aa338a1c30ce826551e33be6ef877af43b1d8cfd2e1b6ffb70789eb2070d2610fb7cb5cec4a3a4c4a1221767f867f3d2bc07b6b1d9742719b1e053630b24
DIST libseccomp-2.5.0.tar.gz 638793 BLAKE2B c1f30624e210d632175b734c49411ee3f95e8f0ee68819ad83a342434231baef10c292f23fca0127394365a37efb043f9f24ade9534deecd61f50e7111a6fbc8 SHA512 00ef5aeb4db8dafb546ae680b2d6d9b6aeed008df805d0f28f9dd15c074ff6ea7a5e5131ab503825b8011c59aa23046baedd5849ca040aa73352f43ab2d602ae
+DIST libseccomp-2.5.1.tar.gz 189916 BLAKE2B 8d74764a03f154f29fe7a392ce3f7e13d0342cebd875cd2a8e8453aa362d8ee78e8aed466f4f26ea98bda9263283a0cf5ca31f34afacfd7c658de8942fffeea8 SHA512 fcb84b6714dce760387391c42de699897c1767802c4805a71d3221b9cfbc9c3cc20a3122e5f2153e754962faab2f214f892531e5985bacf28875ff1ba9a93996
diff --git a/sys-libs/libseccomp/libseccomp-2.5.1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
new file mode 100644
index 000000000000..cf8f9e8c84dd
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/seccomp/libseccomp.git"
+ PRERELEASE="2.6.0"
+ inherit autotools git-r3
+else
+ #SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/seccomp/libseccomp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa -mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="python static-libs"
+
+REQUIRED_USE="
+ python? (
+ static-libs
+ ${PYTHON_REQUIRED_USE}
+ )"
+
+BDEPEND="
+ dev-util/gperf
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${BDEPEND}"
+RDEPEND="${DEPEND}"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ default
+ if [[ "${PV}" == *9999 ]] ; then
+ sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac
+ fi
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-python
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use python ; then
+ cd "${S}/src/python" || die
+ sed -i -e "s/=.*VERSION_RELEASE.*,/=\"${PRERELEASE}\",/" \
+ -e "/extra_objects/s,\.\.,${OLDPWD}/src," \
+ setup.py || die
+ local -x CPPFLAGS="-I${OLDPWD}/include -I../../include"
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python ; then
+ cd "${S}/src/python" || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "${PN}.la" -delete || die
+ einstalldocs
+}