summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-26 21:01:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-26 21:25:50 +0100
commit9ef6085317434de09eb73b013e468354fdf11854 (patch)
treec5ac3824d2a42bbbf67a18d828e67c6ce8d1e642 /sys-libs/libaal/libaal-1.0.7.ebuild
parentapp-misc/mc: bump up to 4.8.20 (diff)
downloadgentoo-9ef6085317434de09eb73b013e468354fdf11854.tar.gz
gentoo-9ef6085317434de09eb73b013e468354fdf11854.tar.bz2
gentoo-9ef6085317434de09eb73b013e468354fdf11854.zip
sys-libs/libaal: Bump to version 1.0.7
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-libs/libaal/libaal-1.0.7.ebuild')
-rw-r--r--sys-libs/libaal/libaal-1.0.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/libaal/libaal-1.0.7.ebuild b/sys-libs/libaal/libaal-1.0.7.ebuild
new file mode 100644
index 000000000000..78fb9df4d93b
--- /dev/null
+++ b/sys-libs/libaal/libaal-1.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="library required by reiser4progs"
+HOMEPAGE="https://sourceforge.net/projects/reiser4/"
+SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 -sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="virtual/os-headers"
+
+src_prepare() {
+ default
+
+ # remove stupid CFLAG hardcodes
+ sed -i \
+ -e "/GENERIC_CFLAGS/s:-O3::" \
+ -e "/^CFLAGS=/s:\"\":\"${CFLAGS}\":" \
+ configure || die
+ printf '#!/bin/sh\n:\n' > run-ldconfig || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-libminimal
+ --enable-memory-manager
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a aal{,-minimal}
+}