summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-05 16:27:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-05 20:34:53 +0200
commitf9ade7ab153bab64c91a66657b61f9366c2d8344 (patch)
tree839081a8a59e1f4a58ccfa4eb0eb016a25e1d83a /sys-kernel
parentxfce-extra/xfce4-panel-profiles: Bump to 1.0.14 (diff)
downloadgentoo-f9ade7ab153bab64c91a66657b61f9366c2d8344.tar.gz
gentoo-f9ade7ab153bab64c91a66657b61f9366c2d8344.tar.bz2
gentoo-f9ade7ab153bab64c91a66657b61f9366c2d8344.zip
sys-kernel/vanilla-kernel: Bump to 6.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.3.6.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index b06fd8e4a818..ccf02be5efab 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -34,3 +34,5 @@ DIST linux-6.1.31.tar.sign 989 BLAKE2B 86b86704f8e01a31c70a607d572a9ec2d1014cdec
DIST linux-6.1.31.tar.xz 134903408 BLAKE2B a3eec74aa6313f387d22a57d72737cae6c5e60125596fc265c0f7bd90bc95b6f5ef5192028802995a3cb50e739be328711046aadf3adc93dd2047e4b439d4a01 SHA512 1202a47f29eb17ee074ce22289c6cd488acc381a59968728aedb6070874917cf331a2535629775f5ed3c442b5a82ceb17ed41804e719c2d3f81bcf249261bc7b
DIST linux-6.3.5.tar.sign 987 BLAKE2B 34ed1d758eb42af9d27b6aec986c9f52426b19ad9a7483d1b4eb1b4873e7e10efd9c102fa7e17d1fba5df15ba536ab77e6597b607dd07ea9012860fe9eff2c34 SHA512 a701dea5d297c217eb2b497a9441399c0f386f39f74f726f81872f8144d83973ec02ce533b7d48cb9c49d38a98c820668d684927983a001f7a8a27067f605867
DIST linux-6.3.5.tar.xz 136926988 BLAKE2B 646a94591eae93db9301a11e5300579c8cce7d2a544727cb88efed86d05ba070a247498d9c83d7b7cdbead4e7d46537134c877813aa7f188dd36b403c58d0c11 SHA512 91a98c56191645c4ba32f657da59b6be92021b37a698eaf79e1ed3a79b959626386e7b69c8cb0c9eab0645c287a3e53393b1710158eca67b2f66a8d3eaec13de
+DIST linux-6.3.6.tar.sign 987 BLAKE2B db87514c0b906b3faeaeb55235234f32880de042fb2cfb05035186007d3cbbfa1051f80c54b8d9b2f93ca023e393ff3f360b8eb0dcebc3cd388122bc6cf990bb SHA512 f1c9c7d5f81906f45b6c7c2bab251f56a7fcc0ac11f59b5790e1fe5eee3bcca16da841d70055f15de4d03c24ef611520ea4339d989f4ab89354382997bebd148
+DIST linux-6.3.6.tar.xz 136895308 BLAKE2B 73afc625bbdce52a288724f17a42603b45c9e107a8055172d218369d16885ab9e3ecc1358be5bc839c53ae40c9005b673de6f08bb2cbf36873a19b3ebdb69218 SHA512 2ec7f13bc9e0b15652830af0282895bd0b20d4969b1b3e30890373e3e1ec7591525a67c0e2a7e9e3a565ef3cf053595fa8bfc960a8eafa5847d7db5e7bc038b1
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.6.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.6.ebuild
new file mode 100644
index 000000000000..98a956be057f
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.3.6.ebuild
@@ -0,0 +1,137 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.3.1-gentoo
+GENTOO_CONFIG_VER=g7
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}