summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLabbe Corentin <clabbe.montjoie@gmail.com>2018-04-09 11:59:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-10 14:21:31 +0200
commitd8fcfed03eec36f78ee20b18fbcd673e05e81ebb (patch)
tree01445d83d79580b87ed5dff4e99ef3c74b27a4f5 /sys-kernel/cryptodev
parentsys-fs/zfs: Replacing 0.7.7 with 0.7.8. Removing 0.7.7 Package Mask. (diff)
downloadgentoo-d8fcfed03eec36f78ee20b18fbcd673e05e81ebb.tar.gz
gentoo-d8fcfed03eec36f78ee20b18fbcd673e05e81ebb.tar.bz2
gentoo-d8fcfed03eec36f78ee20b18fbcd673e05e81ebb.zip
sys-kernel/cryptodev: fix bug 629958
Add an upstream patch for allowing cryptodev to build with kernel >= 4.13 Closes: https://bugs.gentoo.org/629958 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7807
Diffstat (limited to 'sys-kernel/cryptodev')
-rw-r--r--sys-kernel/cryptodev/cryptodev-1.9.ebuild4
-rw-r--r--sys-kernel/cryptodev/files/cryptodev-1.9-fix-build-with-4.14-629958.patch44
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-1.9.ebuild b/sys-kernel/cryptodev/cryptodev-1.9.ebuild
index 3f606909802d..e4e62d997e60 100644
--- a/sys-kernel/cryptodev/cryptodev-1.9.ebuild
+++ b/sys-kernel/cryptodev/cryptodev-1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,8 @@ S=${WORKDIR}/${PN}-linux-${PV}
MODULE_NAMES="cryptodev(extra:${S})"
+PATCHES="${FILESDIR}/cryptodev-1.9-fix-build-with-4.14-629958.patch"
+
pkg_pretend() {
if use kernel_linux ; then
CONFIG_CHECK="~CRYPTO ~CRYPTO_BLKCIPHER ~CRYPTO_AEAD"
diff --git a/sys-kernel/cryptodev/files/cryptodev-1.9-fix-build-with-4.14-629958.patch b/sys-kernel/cryptodev/files/cryptodev-1.9-fix-build-with-4.14-629958.patch
new file mode 100644
index 000000000000..8a78d5ec8765
--- /dev/null
+++ b/sys-kernel/cryptodev/files/cryptodev-1.9-fix-build-with-4.14-629958.patch
@@ -0,0 +1,44 @@
+From f0d69774afb27ffc62bf353465fba145e70cb85a Mon Sep 17 00:00:00 2001
+From: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
+Date: Mon, 4 Sep 2017 11:05:08 +0200
+Subject: [PATCH] ioctl.c: Fix build with linux 4.13
+
+git/ioctl.c:1127:3: error: positional initialization of field in 'struct' declared with 'designated_init' attribute [-Werror=designated-init]
+ {0, },
+ ^
+note: (near initialization for 'verbosity_ctl_dir[1]')
+git/ioctl.c:1136:3: error: positional initialization of field in 'struct' declared with 'designated_init' attribute [-Werror=designated-init]
+ {0, },
+ ^
+
+Linux kernel has added -Werror=designated-init around 4.11 (c834f0e8a8b)
+triggering build errors with gcc 5 and 6 (but not with gcc 4)
+
+Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
+Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
+---
+ ioctl.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ioctl.c b/ioctl.c
+index 0385203..8d4a162 100644
+--- a/ioctl.c
++++ b/ioctl.c
+@@ -1124,7 +1124,7 @@ static struct ctl_table verbosity_ctl_dir[] = {
+ .mode = 0644,
+ .proc_handler = proc_dointvec,
+ },
+- {0, },
++ {},
+ };
+
+ static struct ctl_table verbosity_ctl_root[] = {
+@@ -1133,7 +1133,7 @@ static struct ctl_table verbosity_ctl_root[] = {
+ .mode = 0555,
+ .child = verbosity_ctl_dir,
+ },
+- {0, },
++ {},
+ };
+ static struct ctl_table_header *verbosity_sysctl_header;
+ static int __init init_cryptodev(void)