summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-07-14 13:18:53 -0500
committerBen Kohler <bkohler@gentoo.org>2021-07-14 13:22:46 -0500
commit7810ae331275b752a2ac6f81153a5b87eaab0190 (patch)
treeb1551e8e77b7c5221c97c4a2aed66a31bfa7caa0 /sys-fs/udiskie
parentdev-python/python-keyutils: new package needed for udiskie tests (diff)
downloadgentoo-7810ae331275b752a2ac6f81153a5b87eaab0190.tar.gz
gentoo-7810ae331275b752a2ac6f81153a5b87eaab0190.tar.bz2
gentoo-7810ae331275b752a2ac6f81153a5b87eaab0190.zip
sys-fs/udiskie: enable tests, bump to EAPI=8
Closes: https://bugs.gentoo.org/802063 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-fs/udiskie')
-rw-r--r--sys-fs/udiskie/udiskie-2.3.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/udiskie/udiskie-2.3.3-r1.ebuild b/sys-fs/udiskie/udiskie-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..b03588a5d916
--- /dev/null
+++ b/sys-fs/udiskie/udiskie-2.3.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="An automatic disk mounting service using udisks"
+HOMEPAGE="https://pypi.org/project/udiskie/ https://github.com/coldfix/udiskie"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ sys-fs/udisks:2"
+DEPEND="app-text/asciidoc
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:gtk-update-icon-cache:true:' setup.py || die
+ default
+
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ emake -C doc
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/${PN}.8
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}