summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-15 04:24:02 -0400
committerTim Harder <radhermit@gentoo.org>2018-09-15 05:14:37 -0400
commit7c209a52681b85ba2a09900cf80ef88a83cf3d54 (patch)
tree4e6f1fd5d5f75877999a58e68d9a61f313dbfa49 /sys-fs/fuse
parentsys-fs/fuse-common: version bump to 3.2.6 (diff)
downloadgentoo-7c209a52681b85ba2a09900cf80ef88a83cf3d54.tar.gz
gentoo-7c209a52681b85ba2a09900cf80ef88a83cf3d54.tar.bz2
gentoo-7c209a52681b85ba2a09900cf80ef88a83cf3d54.zip
sys-fs/fuse: version bumps to 2.9.8 and 3.2.6
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/Manifest2
-rw-r--r--sys-fs/fuse/fuse-2.9.8.ebuild73
-rw-r--r--sys-fs/fuse/fuse-3.2.6.ebuild74
3 files changed, 149 insertions, 0 deletions
diff --git a/sys-fs/fuse/Manifest b/sys-fs/fuse/Manifest
index fd8493ab518d..6c05fc28ad64 100644
--- a/sys-fs/fuse/Manifest
+++ b/sys-fs/fuse/Manifest
@@ -1,4 +1,6 @@
DIST fuse-2.9.7.tar.gz 661138 BLAKE2B 8e56cfa8634e919bfc4f9fa589074763bd8c272d5166a2a6fd7d416477ca07a374611639283593df4b06f8d5820b8cf5a375463d4b85fa3644868b2a62611003 SHA512 f47304d9c7a1815f7a2905b7bdb7785d4c10292a80c8dc1ec45d895af96bc6ffd6d84ff2617bd976a1d0867ab8ec1a404a5a05ace85a69ecca830f371d08f8e2
+DIST fuse-2.9.8.tar.gz 4610904 BLAKE2B 803eebea510834676379df8c9514050efcf47d83c06ba1f5b5756d27f5c32d3a0cc199d826b0c041118c5d2260ff023f58432a0d7b623807c0a4af4da7c34eff SHA512 0a9b14d96c6f98f5c903baf00114bfff72f9aeb97224702bbed370516b2b582401d5b436fcef979918ffd85d69ba4a82c8f722c0b35ebd50f7aa5f4ddfdcf8ad
DIST fuse-3.2.1.tar.xz 1042772 BLAKE2B fe7dccc3b791a3b549815f5015a993c29d9481742a88b0291a03b39b95c0acb709969bdc0f6fbea5a48d0bb97bc362ad351b719d77a4f9f630825308f3fb1913 SHA512 edf08711fa02c40b9d3507c99e0b1bfd7208edc1494888c4e2bad92b621eb5c43c4cb31474d2d3bb1edaaf9cd876f3407cdb00a1bdcf61a0b74c876d3707518e
DIST fuse-3.2.2.tar.xz 1187816 BLAKE2B 4cda342ded747a92f31417c32006e202398555d2112134f403addd1f2ef896ed46e1082a13437e657795ae93b67fb2692746b759b9efb3bd8c70857623ca1af6 SHA512 234256ed8e9e277557775d34b0aa77f3b0a3c40a715e52db1437f2ffd2a7d8eda2e12ef35963a918b3310f7244bba9b3755003a25b98ea6d29b6d4b322cddec7
DIST fuse-3.2.3.tar.xz 1238628 BLAKE2B 07b073d0af9d8db3b8799d872225f0637351b99bafb5db11b45dab1173101669731de66215a31e2141cfe5aa6d467e87d469f432194ddf7b8d5eb8e10825d679 SHA512 f91ee4b24df64e62d0c50db0bc3807229cfde06da118c87826bc3ee01b41689ec93a96b026226e948e6d7904bb506dc1d8ffa83d29aa12ea7f17009f6060263e
+DIST fuse-3.2.6.tar.xz 1456220 BLAKE2B 9b09504ed04abd0134188c28f3908e69e3416c345a96aefbca0f64447f3c3a8907550874f5fec9cd8f65fbaa892be6cc0213a7f61d7ad51c955ce3acf955ee17 SHA512 3a1ef77ab4c79a24aad0b259e17f568a30a5faf53ac17eb25d05f30dc7423f0081583f5b3c284ca9196a01885843e97c323a84231272b7e2b55c8e73848a61b8
diff --git a/sys-fs/fuse/fuse-2.9.8.ebuild b/sys-fs/fuse/fuse-2.9.8.ebuild
new file mode 100644
index 000000000000..179face680f2
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.9.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit ltprune libtool linux-info udev toolchain-funcs
+
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+DEPEND="virtual/pkgconfig"
+RDEPEND="sys-fs/fuse-common"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ local PATCHES=( "${FILESDIR}"/${PN}-2.9.3-kernel-types.patch )
+ # sandbox violation with mtab writability wrt #438250
+ # don't sed configure.in without eautoreconf because of maintainer mode
+ sed -i 's:umount --fake:true --fake:' configure || die
+ elibtoolize
+
+ default
+}
+
+src_configure() {
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/$(get_udevdir)/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog README.md README.NFS NEWS doc/how-fuse-works doc/kernel.txt )
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+
+ if use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+
+ prune_libtool_files
+
+ # installed via fuse-common
+ rm -r "${ED%/}"/{etc,$(get_udevdir)} || die
+ rm "${ED%/}"/usr/share/man/man8/mount.fuse.* || die
+ rm "${ED%/}"/sbin/mount.fuse || die
+
+ # handled by the device manager
+ rm -r "${D%/}"/dev || die
+}
diff --git a/sys-fs/fuse/fuse-3.2.6.ebuild b/sys-fs/fuse/fuse-3.2.6.ebuild
new file mode 100644
index 000000000000..4012fc673b62
--- /dev/null
+++ b/sys-fs/fuse/fuse-3.2.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit meson multilib-minimal flag-o-matic udev python-any-r1
+
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="virtual/pkgconfig
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+RDEPEND="sys-fs/fuse-common"
+
+DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt )
+
+python_check_deps() {
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # lto not supported yet -- https://github.com/libfuse/libfuse/issues/198
+ filter-flags -flto*
+
+ # passthough_ll is broken on systems with 32-bit pointers
+ cat /dev/null > example/meson.build || die
+}
+
+multilib_src_configure() {
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_test() {
+ ${EPYTHON} -m pytest test || die
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # installed via fuse-common
+ rm -r "${ED%/}"/{etc,$(get_udevdir)} || die
+ rm "${ED%/}"/usr/sbin/mount.fuse3 || die
+
+ # handled by the device manager
+ rm -r "${ED%/}"/dev || die
+
+ # manually install man pages
+ rm -r "${ED%/}"/usr/share/man || die
+ doman doc/fusermount3.1
+}