summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock <gentoo@mattwhitlock.name>2023-04-15 16:24:41 -0400
committerViorel Munteanu <ceamac@gentoo.org>2023-04-16 15:25:56 +0300
commit6b6835d6628c39fa13ae6183ee9a0fb69ca77a1f (patch)
treed12fbee27bcfa2c6b1b46c769eaf5b50ba92cdef /sys-fs/f2fs-tools
parentsci-mathematics/arb: keyword 2.23.0 for ~loong (diff)
downloadgentoo-6b6835d6628c39fa13ae6183ee9a0fb69ca77a1f.tar.gz
gentoo-6b6835d6628c39fa13ae6183ee9a0fb69ca77a1f.tar.bz2
gentoo-6b6835d6628c39fa13ae6183ee9a0fb69ca77a1f.zip
sys-fs/f2fs-tools: add "lz4" and "lzo" USE flags
Closes: https://bugs.gentoo.org/904380 Signed-off-by: Matt Whitlock <gentoo@mattwhitlock.name> Closes: https://github.com/gentoo/gentoo/pull/30609 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild
index 3224cc7ec9ff..f670fbffdbfc 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.16.0.ebuild
@@ -18,11 +18,11 @@ fi
LICENSE="GPL-2"
SLOT="0/10"
-IUSE="selinux"
+IUSE="lz4 lzo selinux"
RDEPEND="
- app-arch/lz4:=
- dev-libs/lzo:2
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
sys-apps/util-linux
selinux? ( sys-libs/libselinux )
elibc_musl? ( sys-libs/queue-standalone )
@@ -38,6 +38,8 @@ src_configure() {
local myconf=(
# This is required to install to /sbin, bug #481110
--bindir="${EPREFIX}"/sbin
+ $(use_with lz4)
+ $(use_with lzo lzo2)
$(use_with selinux)
)