summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-12 23:34:20 +0100
committerSam James <sam@gentoo.org>2022-10-12 23:34:37 +0100
commitfedc8c47f465f04824fc681fd13b1ad1f4067e32 (patch)
tree88ba3f49b1cbd8ef2a3147ef96345d060d996cfb /sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild
parentsys-cluster/rdma-core: add 42.0 (diff)
downloadgentoo-fedc8c47f465f04824fc681fd13b1ad1f4067e32.tar.gz
gentoo-fedc8c47f465f04824fc681fd13b1ad1f4067e32.tar.bz2
gentoo-fedc8c47f465f04824fc681fd13b1ad1f4067e32.zip
sys-fabric/perftest: depend on >=sys-cluster/rdma-core-32.0
Tries to use private symbols. Closes: https://bugs.gentoo.org/774246 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild')
-rw-r--r--sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild b/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild
new file mode 100644
index 000000000000..bfd7e8603e50
--- /dev/null
+++ b/sys-fabric/perftest/perftest-4.4.0.37-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+MY_PV="$(ver_cut 1-2)-$(ver_cut 3-4)"
+
+DESCRIPTION="OpenIB uverbs micro-benchmarks"
+HOMEPAGE="https://github.com/linux-rdma/perftest/"
+SRC_URI="https://github.com/linux-rdma/perftest/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="|| ( GPL-2 BSD-2 )"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+
+DEPEND="
+ sys-apps/pciutils
+ >=sys-cluster/rdma-core-32.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc README runme
+ dobin ib_*
+}