summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-devel
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-6.1-r1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-6.3-r2.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-7.0-r1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-7.1-r1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-7.2-r1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-8.1.ebuild1
-rw-r--r--sys-devel/binutils-apple/binutils-apple-8.2.1-r1.ebuild1
-rw-r--r--sys-devel/bison/bison-3.1.ebuild3
-rw-r--r--sys-devel/bison/bison-3.2.4.ebuild3
-rw-r--r--sys-devel/bison/bison-3.3.2.ebuild1
-rw-r--r--sys-devel/bison/bison-3.4.1.ebuild1
-rw-r--r--sys-devel/bison/bison-3.4.2.ebuild1
-rw-r--r--sys-devel/flex/flex-2.6.1.ebuild3
-rw-r--r--sys-devel/flex/flex-2.6.3-r1.ebuild3
-rw-r--r--sys-devel/flex/flex-2.6.3.ebuild3
-rw-r--r--sys-devel/flex/flex-2.6.4-r1.ebuild1
-rw-r--r--sys-devel/flex/flex-2.6.4.ebuild3
-rw-r--r--sys-devel/patch/patch-2.7.6-r4.ebuild1
-rw-r--r--sys-devel/sparse/sparse-0.5.1.ebuild3
-rw-r--r--sys-devel/sparse/sparse-0.5.2_rc1.ebuild3
-rw-r--r--sys-devel/sparse/sparse-0.6.0.ebuild1
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild1
25 files changed, 33 insertions, 8 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild b/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
index b22d2eadae76..f959d52dadb7 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
@@ -24,6 +24,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test multitarget"
+RESTRICT="!test? ( test )"
RDEPEND="sys-devel/binutils-config
lto? ( sys-devel/llvm:* )"
diff --git a/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
index 8054c9ae0d53..e2bead82b9e7 100644
--- a/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
@@ -23,6 +23,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test libcxx multitarget"
+RESTRICT="!test? ( test )"
RDEPEND="sys-devel/binutils-config
lto? ( sys-devel/llvm:* )
diff --git a/sys-devel/binutils-apple/binutils-apple-6.1-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-6.1-r1.ebuild
index 8d7aa6d2cf36..3e68d58f0b9f 100644
--- a/sys-devel/binutils-apple/binutils-apple-6.1-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-6.1-r1.ebuild
@@ -24,6 +24,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test libcxx multitarget"
+RESTRICT="!test? ( test )"
RDEPEND="sys-devel/binutils-config
lto? ( sys-devel/llvm:* )
diff --git a/sys-devel/binutils-apple/binutils-apple-6.3-r2.ebuild b/sys-devel/binutils-apple/binutils-apple-6.3-r2.ebuild
index c84b2b5c8f2d..2471067df89b 100644
--- a/sys-devel/binutils-apple/binutils-apple-6.3-r2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-6.3-r2.ebuild
@@ -25,6 +25,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test libcxx multitarget"
+RESTRICT="!test? ( test )"
RDEPEND="sys-devel/binutils-config
lto? ( sys-devel/llvm:* )
diff --git a/sys-devel/binutils-apple/binutils-apple-7.0-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-7.0-r1.ebuild
index 6082903fa5af..26cdc62a049f 100644
--- a/sys-devel/binutils-apple/binutils-apple-7.0-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-7.0-r1.ebuild
@@ -26,6 +26,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test multitarget"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massivley uses
# C++11 language fatures. *But additionally* the as driver now defaults to
diff --git a/sys-devel/binutils-apple/binutils-apple-7.1-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-7.1-r1.ebuild
index 98eccefbd990..1726e46df84b 100644
--- a/sys-devel/binutils-apple/binutils-apple-7.1-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-7.1-r1.ebuild
@@ -26,6 +26,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test multitarget"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massivley uses
# C++11 language fatures. *But additionally* the as driver now defaults to
diff --git a/sys-devel/binutils-apple/binutils-apple-7.2-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-7.2-r1.ebuild
index ac2ac3a6ec47..2c95149c0179 100644
--- a/sys-devel/binutils-apple/binutils-apple-7.2-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-7.2-r1.ebuild
@@ -27,6 +27,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test multitarget"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massivley uses
# C++11 language fatures. *But additionally* the as driver now defaults to
diff --git a/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild b/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
index b903419b7ccf..6c1ac5689e24 100644
--- a/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
@@ -28,6 +28,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="lto test multitarget"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massively uses
# C++11 language features. *But additionally* the as driver now defaults to
diff --git a/sys-devel/binutils-apple/binutils-apple-8.1.ebuild b/sys-devel/binutils-apple/binutils-apple-8.1.ebuild
index 0658f9816910..ba6816417faf 100644
--- a/sys-devel/binutils-apple/binutils-apple-8.1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-8.1.ebuild
@@ -24,6 +24,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~x64-macos ~x86-macos"
IUSE="lto tapi classic test"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massively uses
# C++11 language features. *But additionally* the as driver now defaults to
diff --git a/sys-devel/binutils-apple/binutils-apple-8.2.1-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-8.2.1-r1.ebuild
index 7df83c36da89..2ff38c2b3909 100644
--- a/sys-devel/binutils-apple/binutils-apple-8.2.1-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-8.2.1-r1.ebuild
@@ -23,6 +23,7 @@ SRC_URI="http://www.opensource.apple.com/tarballs/ld64/${LD64}.tar.gz
LICENSE="APSL-2"
KEYWORDS="~x64-macos ~x86-macos"
IUSE="lto tapi classic test"
+RESTRICT="!test? ( test )"
# ld64 can now only be compiled using llvm and libc++ since it massively uses
# C++11 language features. *But additionally* the as driver now defaults to
diff --git a/sys-devel/bison/bison-3.1.ebuild b/sys-devel/bison/bison-3.1.ebuild
index 837f2d7c557b..3bc7317ee6b9 100644
--- a/sys-devel/bison/bison-3.1.ebuild
+++ b/sys-devel/bison/bison-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
diff --git a/sys-devel/bison/bison-3.2.4.ebuild b/sys-devel/bison/bison-3.2.4.ebuild
index 0357b2808cf2..ee2921faf934 100644
--- a/sys-devel/bison/bison-3.2.4.ebuild
+++ b/sys-devel/bison/bison-3.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,6 +17,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
diff --git a/sys-devel/bison/bison-3.3.2.ebuild b/sys-devel/bison/bison-3.3.2.ebuild
index 365abc303bf2..e1a98b18d8b8 100644
--- a/sys-devel/bison/bison-3.3.2.ebuild
+++ b/sys-devel/bison/bison-3.3.2.ebuild
@@ -17,6 +17,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
diff --git a/sys-devel/bison/bison-3.4.1.ebuild b/sys-devel/bison/bison-3.4.1.ebuild
index 404b47906d07..26796c92d9c5 100644
--- a/sys-devel/bison/bison-3.4.1.ebuild
+++ b/sys-devel/bison/bison-3.4.1.ebuild
@@ -17,6 +17,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
diff --git a/sys-devel/bison/bison-3.4.2.ebuild b/sys-devel/bison/bison-3.4.2.ebuild
index c09c53ba4c22..017e3599a181 100644
--- a/sys-devel/bison/bison-3.4.2.ebuild
+++ b/sys-devel/bison/bison-3.4.2.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
RDEPEND=">=sys-devel/m4-1.4.16"
DEPEND="${RDEPEND}
diff --git a/sys-devel/flex/flex-2.6.1.ebuild b/sys-devel/flex/flex-2.6.1.ebuild
index ea2654c2a948..0a9a08e4c5a0 100644
--- a/sys-devel/flex/flex-2.6.1.ebuild
+++ b/sys-devel/flex/flex-2.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,6 +13,7 @@ LICENSE="FLEX"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static test"
+RESTRICT="!test? ( test )"
# We want bison explicitly and not yacc in general #381273
RDEPEND="sys-devel/m4"
diff --git a/sys-devel/flex/flex-2.6.3-r1.ebuild b/sys-devel/flex/flex-2.6.3-r1.ebuild
index fc2f132f8480..ecb6e84db261 100644
--- a/sys-devel/flex/flex-2.6.3-r1.ebuild
+++ b/sys-devel/flex/flex-2.6.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,6 +13,7 @@ LICENSE="FLEX"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static test"
+RESTRICT="!test? ( test )"
# We want bison explicitly and not yacc in general #381273
RDEPEND="sys-devel/m4"
diff --git a/sys-devel/flex/flex-2.6.3.ebuild b/sys-devel/flex/flex-2.6.3.ebuild
index 97a289f17801..2f3c3a49c49c 100644
--- a/sys-devel/flex/flex-2.6.3.ebuild
+++ b/sys-devel/flex/flex-2.6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,6 +13,7 @@ LICENSE="FLEX"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static test"
+RESTRICT="!test? ( test )"
# We want bison explicitly and not yacc in general #381273
RDEPEND="sys-devel/m4"
diff --git a/sys-devel/flex/flex-2.6.4-r1.ebuild b/sys-devel/flex/flex-2.6.4-r1.ebuild
index caa31dc2a83e..bbff68ffa968 100644
--- a/sys-devel/flex/flex-2.6.4-r1.ebuild
+++ b/sys-devel/flex/flex-2.6.4-r1.ebuild
@@ -13,6 +13,7 @@ LICENSE="FLEX"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static test"
+RESTRICT="!test? ( test )"
# We want bison explicitly and not yacc in general #381273
RDEPEND="sys-devel/m4"
diff --git a/sys-devel/flex/flex-2.6.4.ebuild b/sys-devel/flex/flex-2.6.4.ebuild
index 04b4927aad56..7b2cb965404b 100644
--- a/sys-devel/flex/flex-2.6.4.ebuild
+++ b/sys-devel/flex/flex-2.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,6 +13,7 @@ LICENSE="FLEX"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="nls static test"
+RESTRICT="!test? ( test )"
# We want bison explicitly and not yacc in general #381273
RDEPEND="sys-devel/m4"
diff --git a/sys-devel/patch/patch-2.7.6-r4.ebuild b/sys-devel/patch/patch-2.7.6-r4.ebuild
index 1fbe08e714b4..16b8e20018b3 100644
--- a/sys-devel/patch/patch-2.7.6-r4.ebuild
+++ b/sys-devel/patch/patch-2.7.6-r4.ebuild
@@ -13,6 +13,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static test xattr"
+RESTRICT="!test? ( test )"
RDEPEND="xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}
diff --git a/sys-devel/sparse/sparse-0.5.1.ebuild b/sys-devel/sparse/sparse-0.5.1.ebuild
index 75591c9bf3a5..42e03465b179 100644
--- a/sys-devel/sparse/sparse-0.5.1.ebuild
+++ b/sys-devel/sparse/sparse-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
+RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
llvm? ( >=sys-devel/llvm-3.0 )
diff --git a/sys-devel/sparse/sparse-0.5.2_rc1.ebuild b/sys-devel/sparse/sparse-0.5.2_rc1.ebuild
index 69c8ce4c6c75..345c634dc184 100644
--- a/sys-devel/sparse/sparse-0.5.2_rc1.ebuild
+++ b/sys-devel/sparse/sparse-0.5.2_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
+RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
llvm? ( >=sys-devel/llvm-3.0 )
diff --git a/sys-devel/sparse/sparse-0.6.0.ebuild b/sys-devel/sparse/sparse-0.6.0.ebuild
index 3276afff1988..fa4c7a97fab9 100644
--- a/sys-devel/sparse/sparse-0.6.0.ebuild
+++ b/sys-devel/sparse/sparse-0.6.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
+RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
llvm? ( >=sys-devel/llvm-3.0 )
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 3276afff1988..fa4c7a97fab9 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
+RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
llvm? ( >=sys-devel/llvm-3.0 )