summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-07 15:39:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-07 15:39:23 +0100
commit064179503974a96153ed6ec09a924f90f7514549 (patch)
tree313a804be902507181b161643a56fbbe4df8284d /sys-devel/lld-toolchain-symlinks
parentsys-devel/llvm-common: Remove 15.0.5 (diff)
downloadgentoo-064179503974a96153ed6ec09a924f90f7514549.tar.gz
gentoo-064179503974a96153ed6ec09a924f90f7514549.tar.bz2
gentoo-064179503974a96153ed6ec09a924f90f7514549.zip
sys-devel/lld-toolchain-symlinks: Remove the -r1s
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/lld-toolchain-symlinks')
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r1.ebuild39
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15-r1.ebuild39
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16-r1.ebuild40
3 files changed, 0 insertions, 118 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r1.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r1.ebuild
deleted file mode 100644
index c1a6e31f926c..000000000000
--- a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use LLD on binutils-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-SRC_URI=""
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="multilib-symlinks +native-symlinks"
-
-RDEPEND="
- sys-devel/lld
-"
-
-src_install() {
- use native-symlinks || return
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- dosym ../../../../bin/ld.lld "${dest}/ld"
- for chost in "${chosts[@]}"; do
- dosym ../../../../bin/ld.lld "${dest}/${chost}-ld"
- done
-}
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15-r1.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15-r1.ebuild
deleted file mode 100644
index c1a6e31f926c..000000000000
--- a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-15-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use LLD on binutils-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-SRC_URI=""
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="multilib-symlinks +native-symlinks"
-
-RDEPEND="
- sys-devel/lld
-"
-
-src_install() {
- use native-symlinks || return
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- dosym ../../../../bin/ld.lld "${dest}/ld"
- for chost in "${chosts[@]}"; do
- dosym ../../../../bin/ld.lld "${dest}/${chost}-ld"
- done
-}
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16-r1.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16-r1.ebuild
deleted file mode 100644
index 0fc37704b2b3..000000000000
--- a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use LLD on binutils-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-SRC_URI=""
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS=""
-PROPERTIES="live"
-IUSE="multilib-symlinks +native-symlinks"
-
-RDEPEND="
- sys-devel/lld
-"
-
-src_install() {
- use native-symlinks || return
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- dosym ../../../../bin/ld.lld "${dest}/ld"
- for chost in "${chosts[@]}"; do
- dosym ../../../../bin/ld.lld "${dest}/${chost}-ld"
- done
-}