summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 11:32:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 11:34:11 +0100
commita1ca70ca964ea2d728d209075f8975a1c136b209 (patch)
treedf90f43342c6511c12f408db5a9fdfa6db33cac6 /sys-devel/clang
parentdev-vcs/git-2.29.2: don't build osxkeychain module with gcc (diff)
downloadgentoo-a1ca70ca964ea2d728d209075f8975a1c136b209.tar.gz
gentoo-a1ca70ca964ea2d728d209075f8975a1c136b209.tar.bz2
gentoo-a1ca70ca964ea2d728d209075f8975a1c136b209.zip
sys-devel/clang: Fix missing conditions around deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-11.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang/clang-12.0.0.9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/clang/clang-11.0.0.9999.ebuild b/sys-devel/clang/clang-11.0.0.9999.ebuild
index 7be842f5ff25..1e9b8aabd110 100644
--- a/sys-devel/clang/clang-11.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-11.0.0.9999.ebuild
@@ -36,7 +36,7 @@ RDEPEND="
${PYTHON_DEPS}"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}:${SLOT}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}:${SLOT}[${x}] )"
done
unset x
diff --git a/sys-devel/clang/clang-12.0.0.9999.ebuild b/sys-devel/clang/clang-12.0.0.9999.ebuild
index 83d795ccdb65..d1d26af0fa7c 100644
--- a/sys-devel/clang/clang-12.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-12.0.0.9999.ebuild
@@ -36,7 +36,7 @@ RDEPEND="
${PYTHON_DEPS}"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}:${SLOT}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}:${SLOT}[${x}] )"
done
unset x