summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-09 16:26:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-09 16:28:15 +0100
commit850d62746d6c2ed52780cf4e31f6f0963c5be4a6 (patch)
treea80b2e03a5d90aaee25725450998b965e76a3c99 /sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild
parentdev-ml/llvm-ocaml: Bump to 11.1.0-rc3 (diff)
downloadgentoo-850d62746d6c2ed52780cf4e31f6f0963c5be4a6.tar.gz
gentoo-850d62746d6c2ed52780cf4e31f6f0963c5be4a6.tar.bz2
gentoo-850d62746d6c2ed52780cf4e31f6f0963c5be4a6.zip
sys-devel/clang-common: Bump to 11.1.0-rc3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild b/sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild
new file mode 100644
index 000000000000..03e4441b91b9
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-11.1.0_rc3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}