summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-17 08:49:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-17 08:49:11 -0500
commit59ab450e7a612e0215ecb7a5acb9de4c414b255d (patch)
tree51b452383cd1d71e7a111513337ceb9665b69a02 /sys-cluster
parentnet-im/mattermost-desktop-bin: fix absolute symlink (diff)
downloadgentoo-59ab450e7a612e0215ecb7a5acb9de4c414b255d.tar.gz
gentoo-59ab450e7a612e0215ecb7a5acb9de4c414b255d.tar.bz2
gentoo-59ab450e7a612e0215ecb7a5acb9de4c414b255d.zip
sys-cluster/swift: migration to user packages
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/metadata.xml4
-rw-r--r--sys-cluster/swift/swift-2.23.1-r2.ebuild (renamed from sys-cluster/swift/swift-2.23.1-r1.ebuild)18
2 files changed, 7 insertions, 15 deletions
diff --git a/sys-cluster/swift/metadata.xml b/sys-cluster/swift/metadata.xml
index 14aa35f3e4a6..6a12c88d2a76 100644
--- a/sys-cluster/swift/metadata.xml
+++ b/sys-cluster/swift/metadata.xml
@@ -16,10 +16,6 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
- <longdescription lang="en">
- Swift is a highly available, distributed, eventually consistent object/blob
- store.
- </longdescription>
<upstream>
<remote-id type="launchpad">swift</remote-id>
</upstream>
diff --git a/sys-cluster/swift/swift-2.23.1-r1.ebuild b/sys-cluster/swift/swift-2.23.1-r2.ebuild
index 81130d620e21..0209967c131d 100644
--- a/sys-cluster/swift/swift-2.23.1-r1.ebuild
+++ b/sys-cluster/swift/swift-2.23.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 python3_7 )
-inherit distutils-r1 eutils linux-info user
+inherit distutils-r1 eutils linux-info
DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
HOMEPAGE="https://launchpad.net/swift"
@@ -19,7 +19,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="account container doc +memcached object proxy"
+IUSE="account container doc +memcached +object proxy"
REQUIRED_USE="|| ( proxy account container object )"
CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
@@ -40,7 +40,9 @@ RDEPEND="
>=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
memcached? ( net-misc/memcached )
- net-misc/rsync[xattr]"
+ net-misc/rsync[xattr]
+ acct-user/swift
+ acct-group/swift"
pkg_pretend() {
linux-info_pkg_setup
@@ -54,11 +56,6 @@ pkg_pretend() {
fi
}
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
src_prepare() {
sed -i 's/xattr/pyxattr/g' requirements.txt || die
sed -i '/^hacking/d' test-requirements.txt || die
@@ -87,8 +84,7 @@ python_install_all() {
newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
newins "etc/proxy-server.conf-sample" "proxy-server.conf"
if use memcached; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
+ sed -i '/depend/a\ need memcached' "${D}/etc/init.d/swift-proxy"
fi
fi
if use account; then