summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2018-03-02 10:36:50 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-03 11:59:57 +0100
commita9bc35a731fda6b0a1fb61df0ef52e0176dbe8e8 (patch)
treed79b03f6f57b8c6409d0c84e969921dd396b6297 /sys-cluster/teleport
parentprofiles/arch/arm64: Mask more flags with missing deps (diff)
downloadgentoo-a9bc35a731fda6b0a1fb61df0ef52e0176dbe8e8.tar.gz
gentoo-a9bc35a731fda6b0a1fb61df0ef52e0176dbe8e8.tar.bz2
gentoo-a9bc35a731fda6b0a1fb61df0ef52e0176dbe8e8.zip
sys-cluster/teleport: add v2.4.2
Closes: https://github.com/gentoo/gentoo/pull/7334
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-2.4.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index aef2060eb503..cafc4cbd0473 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1 +1,2 @@
DIST teleport-2.4.0.tar.gz 9967298 BLAKE2B 26cb5610701c4c7deba0ba36b02f43928f4582cd81449045f58281b06a570eb5df762d21e5fef8f7f461855af3ac766fbafd1d2238b6916f9aaaaf07e20b7353 SHA512 4ed3a38fea4ba5acd52aa44cbc36d2bb1cda1fcb304d7787754b1165eefa3d1c8da65e76bf5c33a3f524ecf43b50145f2e850c927b35f2ec754ed90ed507c54d
+DIST teleport-2.4.2.tar.gz 9975909 BLAKE2B 68916e1d15f49448e918b39b2a760f90eca292b07f61e51cfe125eb99c6b36d95a528cfec40b62cd61893ce81edbf5f26066eb59063214369402e2a62d07bd5e SHA512 f9c2f923e05c8fa0b82708955c944e1bd35da2e6bf8b673832e76c91b918a4bc6d6666797faf0f7572cfaa7341991ef8937cd9b374cdc273271aff45f96b2960
diff --git a/sys-cluster/teleport/teleport-2.4.2.ebuild b/sys-cluster/teleport/teleport-2.4.2.ebuild
new file mode 100644
index 000000000000..dc7173e18dc7
--- /dev/null
+++ b/sys-cluster/teleport/teleport-2.4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils golang-build systemd user
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE=""
+LICENSE="Apache-2.0"
+RESTRICT="test strip"
+SLOT="0"
+
+DEPEND="
+ app-arch/zip
+ >=dev-lang/go-1.8.3"
+RDEPEND=""
+
+src_compile() {
+ GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}