summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-28 17:57:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:22:57 +0100
commitd376c7b53124bcf3dc8757fc006f703bd9a65b2e (patch)
tree3d877b52286862c6ff86b0f782f90903f81c75b2 /sys-cluster/nova
parentsys-cluster/cinder: Drop python2_7 (diff)
downloadgentoo-d376c7b53124bcf3dc8757fc006f703bd9a65b2e.tar.gz
gentoo-d376c7b53124bcf3dc8757fc006f703bd9a65b2e.tar.bz2
gentoo-d376c7b53124bcf3dc8757fc006f703bd9a65b2e.zip
sys-cluster/nova: Drop python2_7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/nova-18.2.3.ebuild3
-rw-r--r--sys-cluster/nova/nova-19.0.3.ebuild3
-rw-r--r--sys-cluster/nova/nova-20.0.1.ebuild3
-rw-r--r--sys-cluster/nova/nova-2018.2.9999.ebuild3
-rw-r--r--sys-cluster/nova/nova-2019.1.9999.ebuild3
-rw-r--r--sys-cluster/nova/nova-2019.2.9999.ebuild3
6 files changed, 6 insertions, 12 deletions
diff --git a/sys-cluster/nova/nova-18.2.3.ebuild b/sys-cluster/nova/nova-18.2.3.ebuild
index f57c926d0e3e..e46324c4bd73 100644
--- a/sys-cluster/nova/nova-18.2.3.ebuild
+++ b/sys-cluster/nova/nova-18.2.3.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/futures-3.0.0[$(python_gen_usedep 'python2_7')]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]
novncproxy? ( www-apps/novnc )
diff --git a/sys-cluster/nova/nova-19.0.3.ebuild b/sys-cluster/nova/nova-19.0.3.ebuild
index d25e3939bb40..611fe7d129fe 100644
--- a/sys-cluster/nova/nova-19.0.3.ebuild
+++ b/sys-cluster/nova/nova-19.0.3.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]
app-emulation/spice-html5
diff --git a/sys-cluster/nova/nova-20.0.1.ebuild b/sys-cluster/nova/nova-20.0.1.ebuild
index 721b0a62416c..a231a463c242 100644
--- a/sys-cluster/nova/nova-20.0.1.ebuild
+++ b/sys-cluster/nova/nova-20.0.1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -122,7 +122,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
>=dev-python/openstacksdk-0.35.0[${PYTHON_USEDEP}]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]
diff --git a/sys-cluster/nova/nova-2018.2.9999.ebuild b/sys-cluster/nova/nova-2018.2.9999.ebuild
index dd30ccf5b550..38f09f336c86 100644
--- a/sys-cluster/nova/nova-2018.2.9999.ebuild
+++ b/sys-cluster/nova/nova-2018.2.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/futures-3.0.0[$(python_gen_usedep 'python2_7')]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]
novncproxy? ( www-apps/novnc )
diff --git a/sys-cluster/nova/nova-2019.1.9999.ebuild b/sys-cluster/nova/nova-2019.1.9999.ebuild
index 4eaf50a66197..ce48df74dc27 100644
--- a/sys-cluster/nova/nova-2019.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2019.1.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -151,7 +151,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]
app-emulation/spice-html5
diff --git a/sys-cluster/nova/nova-2019.2.9999.ebuild b/sys-cluster/nova/nova-2019.2.9999.ebuild
index 01dac558c9cb..e1d210b52cd0 100644
--- a/sys-cluster/nova/nova-2019.2.9999.ebuild
+++ b/sys-cluster/nova/nova-2019.2.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info multilib user
DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
@@ -122,7 +122,6 @@ RDEPEND="
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
>=dev-python/zVMCloudConnector-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/futurist-1.8.0[$(python_gen_usedep 'python2_7')]
>=dev-python/openstacksdk-0.35.0[${PYTHON_USEDEP}]
dev-python/libvirt-python[${PYTHON_USEDEP}]
app-emulation/libvirt[iscsi?]