summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-05 15:01:07 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-05 15:01:24 -0400
commit979528fd1a15ddb2c202bbf30890cdcc6ef8d0a5 (patch)
tree321fb0fec3b67f954051087ba71eedf0fa55f52a /sys-boot
parentapp-shells/ksh: inherit ninja-utils (diff)
downloadgentoo-979528fd1a15ddb2c202bbf30890cdcc6ef8d0a5.tar.gz
gentoo-979528fd1a15ddb2c202bbf30890cdcc6ef8d0a5.tar.bz2
gentoo-979528fd1a15ddb2c202bbf30890cdcc6ef8d0a5.zip
sys-boot/systemd-boot: drop 245
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/systemd-boot/Manifest1
-rw-r--r--sys-boot/systemd-boot/files/237-libshared-static.patch15
-rw-r--r--sys-boot/systemd-boot/systemd-boot-245.ebuild120
3 files changed, 0 insertions, 136 deletions
diff --git a/sys-boot/systemd-boot/Manifest b/sys-boot/systemd-boot/Manifest
index 9b4446a019cc..209a35c38f4e 100644
--- a/sys-boot/systemd-boot/Manifest
+++ b/sys-boot/systemd-boot/Manifest
@@ -1,2 +1 @@
-DIST systemd-245.tar.gz 8993479 BLAKE2B be0b1fca5ba8585978f570868bc9135c1fee78ea64dcdf8b1a3419e856a83da90104ed2f86e5f3e5b0b6f29d4b34f603bfe1e4cbc61ccf71bedce547db62ff35 SHA512 1b80d0e02472dfc4197f11dab4f56cf90e8a6e105ce19f837cb11335b6d8577ed49031dad94cdb41aa9bdc06ec8eec62c8e9246272b83935e7bb9dcd3cd8c012
DIST systemd-249.tar.gz 10588828 BLAKE2B f7896dea0bdec25125188b94ee84270b972649b1eb16599bed1967ced79f62dbfd1494e22362934f418823c054b342fb24dc57706b49520814beb95b6956bf27 SHA512 0810d09cc32e4aaa4425ee5b7ddf129262b061ce159cbd43571fabda48285243d8f80b566379ece9215d531b9407ee45e1e72c71935644fea31c7bca1bbf540c
diff --git a/sys-boot/systemd-boot/files/237-libshared-static.patch b/sys-boot/systemd-boot/files/237-libshared-static.patch
deleted file mode 100644
index 9966a5f79162..000000000000
--- a/sys-boot/systemd-boot/files/237-libshared-static.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 36a62d280..87f8da29b 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1662,9 +1662,8 @@ if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
- exe = executable('bootctl',
- 'src/boot/bootctl.c',
- include_directories : includes,
-- link_with : [libshared],
-+ link_with : [libshared_static, libsystemd_static],
- dependencies : [libblkid],
-- install_rpath : rootlibexecdir,
- install : true)
- public_programs += [exe]
- endif
diff --git a/sys-boot/systemd-boot/systemd-boot-245.ebuild b/sys-boot/systemd-boot/systemd-boot-245.ebuild
deleted file mode 100644
index 7767ac23cf9d..000000000000
--- a/sys-boot/systemd-boot/systemd-boot-245.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 2016-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson python-any-r1 toolchain-funcs
-
-DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-RESTRICT="test"
-
-BDEPEND="
- ${PYTHON_DEPS}
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt:0
- >=dev-util/intltool-0.50
- dev-util/gperf
- >=dev-util/patchelf-0.10
- virtual/pkgconfig
-"
-COMMON_DEPEND="
- >=sys-apps/util-linux-2.30
-"
-DEPEND="${COMMON_DEPEND}
- >=sys-boot/gnu-efi-3.0.2
- sys-libs/libcap
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd
-"
-
-S="${WORKDIR}/systemd-${PV}"
-
-PATCHES=(
- "${FILESDIR}/237-libshared-static.patch"
-)
-
-src_configure() {
- # https://bugs.gentoo.org/725794
- tc-export OBJCOPY
-
- local emesonargs=(
- -Dblkid=true
- -Defi=true
- -Dgnu-efi=true
- -Defi-cc="$(tc-getCC)"
- -Defi-ld="$(tc-getLD)"
- -Defi-libdir="/usr/$(get_libdir)"
- -Dsplit-usr=true
- -Drootprefix="${EPREFIX:-/}"
-
- -Dacl=false
- -Dapparmor=false
- -Daudit=false
- -Dbzip2=false
- -Delfutils=false
- -Dgcrypt=false
- -Dgnutls=false
- -Dkmod=false
- -Dlibcryptsetup=false
- -Dlibcurl=false
- -Dlibidn=false
- -Dlibidn2=false
- -Dlibiptc=false
- -Dlz4=false
- -Dmicrohttpd=false
- -Dpam=false
- -Dqrencode=false
- -Dseccomp=false
- -Dselinux=false
- -Dxkbcommon=false
- -Dxz=false
- )
- meson_src_configure
-}
-
-set_efi_arch() {
- case "$(tc-arch)" in
- amd64) efi_arch=x64 ;;
- arm) efi_arch=arm ;;
- arm64) efi_arch=aa64 ;;
- x86) efi_arch=x86 ;;
- esac
-}
-
-src_compile() {
- local efi_arch
- set_efi_arch
- local targets=(
- bootctl
- man/bootctl.1
- man/kernel-install.8
- src/boot/efi/linux${efi_arch}.efi.stub
- src/boot/efi/systemd-boot${efi_arch}.efi
- )
- cd "${BUILD_DIR}" || die
- eninja "${targets[@]}"
- patchelf --remove-rpath bootctl || die
-}
-
-src_install() {
- local efi_arch
- set_efi_arch
- dobin "${BUILD_DIR}"/bootctl src/kernel-install/kernel-install
- doman "${BUILD_DIR}"/man/{bootctl.1,kernel-install.8}
- exeinto usr/lib/kernel/install.d
- doexe src/kernel-install/{50-depmod,90-loaderentry}.install
- insinto usr/lib/systemd/boot/efi
- doins "${BUILD_DIR}"/src/boot/efi/{linux${efi_arch}.efi.stub,systemd-boot${efi_arch}.efi}
- einstalldocs
-}