summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2023-12-25 12:55:09 -0800
committerSam James <sam@gentoo.org>2023-12-26 21:24:12 +0000
commit287b32c46ef4a274fe2ae132f5de1af413ffc84a (patch)
treed06cf867c5231c481979a92d9782ccac846f6bae /sys-boot/grub
parentgnome-base/gnome: add 45.2 (diff)
downloadgentoo-287b32c46ef4a274fe2ae132f5de1af413ffc84a.tar.gz
gentoo-287b32c46ef4a274fe2ae132f5de1af413ffc84a.tar.bz2
gentoo-287b32c46ef4a274fe2ae132f5de1af413ffc84a.zip
sys-boot/grub: Use libsdl2 instead of libsdl
Solves this configure error with sdl enabled: checking for SDL2... yes configure: error: SDL support for grub-emu was explicitly requested but can't be compiled (disabled by sdl2) Also fix the fuse dependency to use fuse:3. Bug: https://bugs.gentoo.org/880377 Bug: https://bugs.gentoo.org/920699 Signed-off-by: Zac Medico <zmedico@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34475 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/grub-2.12-r1.ebuild (renamed from sys-boot/grub/grub-2.12.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-boot/grub/grub-2.12.ebuild b/sys-boot/grub/grub-2.12-r1.ebuild
index af2c3e716ed0..80061b9e8e2a 100644
--- a/sys-boot/grub/grub-2.12.ebuild
+++ b/sys-boot/grub/grub-2.12-r1.ebuild
@@ -120,11 +120,11 @@ DEPEND="
app-arch/xz-utils
>=sys-libs/ncurses-5.2-r5:0=
grub_platforms_emu? (
- sdl? ( media-libs/libsdl )
+ sdl? ( media-libs/libsdl2 )
)
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
libzfs? ( sys-fs/zfs:= )
- mount? ( sys-fs/fuse:0 )
+ mount? ( sys-fs/fuse:3 )
truetype? ( media-libs/freetype:2= )
ppc? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
@@ -231,7 +231,8 @@ grub_configure() {
$(use_enable themes grub-themes)
$(use_enable truetype grub-mkfont)
$(use_enable libzfs)
- $(use_enable sdl grub-emu-sdl)
+ --enable-grub-emu-sdl=no
+ $(use_enable sdl grub-emu-sdl2)
${platform:+--with-platform=}${platform}
# Let configure detect this where supported