summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-05-18 23:00:16 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-05-18 23:00:16 +0200
commite4e2ea5bf48e74ec74463b9fc6038fda7807e242 (patch)
tree270d7f55d216621e1b8d5e6280f4a30a8b678589 /sys-block
parentdev-util/intel-graphics-compiler: add 1.0.11222_p20220518 (diff)
downloadgentoo-e4e2ea5bf48e74ec74463b9fc6038fda7807e242.tar.gz
gentoo-e4e2ea5bf48e74ec74463b9fc6038fda7807e242.tar.bz2
gentoo-e4e2ea5bf48e74ec74463b9fc6038fda7807e242.zip
sys-block/partimage: drop 0.6.9-r2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/partimage/files/partimage-0.6.9-zlib-1.2.5.2.patch33
-rw-r--r--sys-block/partimage/partimage-0.6.9-r2.ebuild144
2 files changed, 0 insertions, 177 deletions
diff --git a/sys-block/partimage/files/partimage-0.6.9-zlib-1.2.5.2.patch b/sys-block/partimage/files/partimage-0.6.9-zlib-1.2.5.2.patch
deleted file mode 100644
index 57f87a5d5225..000000000000
--- a/sys-block/partimage/files/partimage-0.6.9-zlib-1.2.5.2.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-http://bugs.gentoo.org/405323
-
---- src/client/imagefile.cpp
-+++ src/client/imagefile.cpp
-@@ -783,7 +783,7 @@
- else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
- {
- showDebug(1, "open gzip\n");
-- m_gzImageFile = (gzFile *) gzdopen(m_nFdImage, "wb"); //"wb1h");
-+ m_gzImageFile = gzdopen(m_nFdImage, "wb"); //"wb1h");
- if (m_gzImageFile == NULL)
- {
- showDebug(1, "error:%d %s\n", errno, strerror(errno));
-@@ -1098,7 +1098,7 @@
- }
- else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
- {
-- m_gzImageFile = (gzFile *) gzdopen(m_nFdImage, "rb");
-+ m_gzImageFile = gzdopen(m_nFdImage, "rb");
- if (m_gzImageFile == NULL)
- THROW(ERR_ERRNO, errno);
- else
---- src/client/imagefile.h
-+++ src/client/imagefile.h
-@@ -41,7 +41,7 @@
- COptions m_options;
-
- FILE *m_fImageFile;
-- gzFile *m_gzImageFile;
-+ gzFile m_gzImageFile;
- BZFILE *m_bzImageFile;
-
- int m_nFdImage;
diff --git a/sys-block/partimage/partimage-0.6.9-r2.ebuild b/sys-block/partimage/partimage-0.6.9-r2.ebuild
deleted file mode 100644
index 34732ed47292..000000000000
--- a/sys-block/partimage/partimage-0.6.9-r2.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools flag-o-matic pam user
-
-DESCRIPTION="Console-based application to efficiently save raw partition data to image file"
-HOMEPAGE="http://www.partimage.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~sparc x86"
-IUSE="nls nologin pam ssl static"
-
-LIBS_DEPEND="app-arch/bzip2
- >=dev-libs/newt-0.52
- >=sys-libs/slang-2
- sys-libs/zlib:=
- !nologin? ( virtual/libcrypt:= )
- ssl? ( dev-libs/openssl:0= )"
-PAM_DEPEND="!static? ( pam? ( sys-libs/pam ) )"
-RDEPEND="${PAM_DEPEND}
- !static? ( ${LIBS_DEPEND} )"
-DEPEND="${PAM_DEPEND}
- ${LIBS_DEPEND}
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- enewgroup partimag 91
- enewuser partimag 91 -1 /var/lib/partimage partimag
-}
-
-src_prepare() {
- eapply -p0 "${FILESDIR}"/${P}-zlib-1.2.5.2.patch #405323
- eapply "${FILESDIR}"/${P}-minor-typo.patch #580290
- eapply "${FILESDIR}"/${P}-openssl-1.1-compatibility.patch
- eapply "${FILESDIR}"/${P}-missing-includes.patch
-
- eapply_user
-
- eautoreconf
-}
-
-src_configure() {
- # XXX: Do we still need these?
- filter-flags -fno-exceptions
- use ppc && append-flags -fsigned-char
-
- local myconf
-
- use nologin && myconf="${myconf} --disable-login"
-
- if use pam && ! use static; then
- myconf="${myconf} --enable-pam"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_enable ssl) \
- --disable-pam \
- $(use_enable static all-static) \
- --with-log-dir="${EPREFIX}"/var/log/partimage \
- ${myconf}
-}
-
-src_install() {
- default
-
- keepdir /var/lib/partimage
- keepdir /var/log/partimage
-
- newinitd "${FILESDIR}"/partimaged.init.2 partimaged
- newconfd "${FILESDIR}"/partimaged.conf partimaged
-
- if use ssl; then
- insinto /etc/partimaged
- doins "${FILESDIR}"/servercert.cnf
- fi
-
- if use pam; then
- newpamd "${FILESDIR}"/partimaged.pam.2 partimaged
- fi
-}
-
-confdir=${EROOT%/}/etc/partimaged
-privkey=${confdir}/partimaged.key
-cnf=${confdir}/servercert.cnf
-csr=${confdir}/partimaged.csr
-cert=${confdir}/partimaged.cert
-
-pkg_config() {
- if use ssl; then
- ewarn "Please customize /etc/partimaged/servercert.cnf before you continue!"
- ewarn "Press Ctrl-C to break now for it, or press enter to continue."
- read
- if [ ! -f ${privkey} ]; then
- einfo "Generating unencrypted private key: ${privkey}"
- openssl genrsa -out ${privkey} 1024 || die
- else
- einfo "Private key already exists: ${privkey}"
- fi
- if [ ! -f ${csr} ]; then
- einfo "Generating certificate request: ${csr}"
- openssl req -new -x509 -outform PEM -out ${csr} -key ${privkey} -config ${cnf} || die
- else
- einfo "Certificate request already exists: ${csr}"
- fi
- if [ ! -f ${cert} ]; then
- einfo "Generating self-signed certificate: ${cert}"
- openssl x509 -in ${csr} -out ${cert} -signkey ${privkey} || die
- else
- einfo "Self-signed certifcate already exists: ${cert}"
- fi
- einfo "Setting permissions"
- partimagesslperms || die
- einfo "Done"
- else
- einfo "SSL is disabled, not building certificates"
- fi
-}
-
-partimagesslperms() {
- local ret=0
- chmod 600 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chown partimag:0 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chmod 644 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- chown root:0 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- return $ret
-}
-
-pkg_postinst() {
- if use ssl; then
- einfo "To create the required SSL certificates, please do:"
- einfo "emerge --config =${PF}"
- partimagesslperms
- return 0
- fi
- chown partimag:0 "${EROOT%/}"/etc/partimaged/partimagedusers || die
-}