summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:38:31 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:38:31 +0100
commit4d257a46b1f254e9c70f551a6ea7770223a10baa (patch)
treedd19420ecc0c807251ac1a14fb8cd707278b4da1 /sys-auth
parentsys-auth/pam_smb: add missing libcrypt dependency, fix *FLAGS (diff)
downloadgentoo-4d257a46b1f254e9c70f551a6ea7770223a10baa.tar.gz
gentoo-4d257a46b1f254e9c70f551a6ea7770223a10baa.tar.bz2
gentoo-4d257a46b1f254e9c70f551a6ea7770223a10baa.zip
sys-auth/pam-pgsql: fix missing libcrypt dependency
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild (renamed from sys-auth/pam-pgsql/pam-pgsql-0.7.3.2.ebuild)16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2.ebuild b/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild
index 56bbf56885ef..656ce64960a5 100644
--- a/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2.ebuild
+++ b/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit pam
-DESCRIPTION="pam module to authenticate users via PostgreSQL"
+DESCRIPTION="PAM module to authenticate users via PostgreSQL"
HOMEPAGE="https://sourceforge.net/projects/pam-pgsql/"
if [[ ${PV} == *_p* ]]; then
@@ -14,16 +14,16 @@ else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
fi
-RDEPEND="sys-libs/pam
- >=dev-db/postgresql-8.0:=
- >=dev-libs/libgcrypt-1.2.0:0="
-
-DEPEND="${RDEPEND}"
-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+RDEPEND=">=dev-db/postgresql-8.0:=
+ >=dev-libs/libgcrypt-1.2.0:0=
+ sys-libs/pam
+ virtual/libcrypt:="
+DEPEND="${RDEPEND}"
+
src_configure() {
econf \
--sysconfdir=/etc/security \