summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/ucspi-ssl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/ucspi-ssl')
-rw-r--r--sys-apps/ucspi-ssl/Manifest1
-rw-r--r--sys-apps/ucspi-ssl/metadata.xml13
-rw-r--r--sys-apps/ucspi-ssl/ucspi-ssl-0.94-r1.ebuild53
3 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/ucspi-ssl/Manifest b/sys-apps/ucspi-ssl/Manifest
new file mode 100644
index 000000000000..f169828b2b8a
--- /dev/null
+++ b/sys-apps/ucspi-ssl/Manifest
@@ -0,0 +1 @@
+DIST ucspi-ssl-0.94.tgz 112640 SHA256 343c0281269d88650823eb053fe80bf34b81f52c12b895f27534706b983a23b4 SHA512 a2b7fcea0da4c99a02cd0cf9402d59e55309a65031232e8afc9f29134be268c2e385840f5616c2046649a3f421563f1abcb707a8a8e93c7d29e7aef4a368b604 WHIRLPOOL 1ef3f5b447810eab97532b7fabaf94c56ddd0818a51f1149ec31ad2265c8899e90c3cf5c497a1c3570fc83918576abca2103132db3a494181ea2a872590fadb2
diff --git a/sys-apps/ucspi-ssl/metadata.xml b/sys-apps/ucspi-ssl/metadata.xml
new file mode 100644
index 000000000000..adbdc3c6c190
--- /dev/null
+++ b/sys-apps/ucspi-ssl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>powerman-asdf@yandex.ru</email>
+ <description>Primary maintainer</description>
+ <name>Alex Efros</name>
+ </maintainer>
+<longdescription>sslserver and sslclient are command-line tools for building SSL
+client-server applications. They conform to the UNIX Client-Server Program
+Interface, UCSPI.</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/ucspi-ssl/ucspi-ssl-0.94-r1.ebuild b/sys-apps/ucspi-ssl/ucspi-ssl-0.94-r1.ebuild
new file mode 100644
index 000000000000..04681e2b5433
--- /dev/null
+++ b/sys-apps/ucspi-ssl/ucspi-ssl-0.94-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fixheadtails qmail
+
+DESCRIPTION="Command-line tools for building SSL client-server applications"
+HOMEPAGE="http://www.fehcom.de/ipnet/ucspi-ssl.html"
+SRC_URI="http://www.fehcom.de/ipnet/ucspi-ssl/${P}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="perl"
+
+DEPEND="
+ >=dev-libs/openssl-0.9.6g:=
+ perl? ( dev-lang/perl:= )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/ucspi-tcp
+"
+
+S="${WORKDIR}"/host/superscript.com/net/${P}/src
+
+src_prepare() {
+ ht_fix_all
+ sed -i -e 's:HOME/command:/usr/bin:' sslcat.sh sslconnect.sh https\@.sh || die
+ sed -i -e 's:auto:gcc:' conf-cc || die
+ sed -i -e 's:-m64::' conf-ld || die
+
+ qmail_set_cc
+
+ echo "/usr/bin" > conf-tcpbin || die
+ echo "/usr/" > home || die
+ echo "/usr/share/ca-certificates/" > conf-cadir || die
+ echo "${QMAIL_HOME}/control/dh1024.pem" > conf-dhfile || die
+}
+
+src_compile() {
+ # build fails without setting to j1
+ emake -j1
+}
+
+src_install() {
+ dodoc ../doc/*
+ doman ../man/*.*
+ dobin sslserver sslclient sslcat sslconnect https\@ || die
+ use perl && dobin sslperl
+}