summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-10 14:54:51 +0000
committerSam James <sam@gentoo.org>2021-01-10 14:54:55 +0000
commitd597caec57cbe19328cbd2d3a026f40c4e8b75df (patch)
tree84311c57ff24e6bcb754a7c789a5c5b3449f6f3b /sys-apps/toybox
parentsys-apps/toybox: bump to 0.8.4 (diff)
downloadgentoo-d597caec57cbe19328cbd2d3a026f40c4e8b75df.tar.gz
gentoo-d597caec57cbe19328cbd2d3a026f40c4e8b75df.tar.bz2
gentoo-d597caec57cbe19328cbd2d3a026f40c4e8b75df.zip
sys-apps/toybox: sync live
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/toybox')
-rw-r--r--sys-apps/toybox/toybox-0.8.4.ebuild4
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild13
2 files changed, 7 insertions, 10 deletions
diff --git a/sys-apps/toybox/toybox-0.8.4.ebuild b/sys-apps/toybox/toybox-0.8.4.ebuild
index 6abff1d6eb86..5b1788940a17 100644
--- a/sys-apps/toybox/toybox-0.8.4.ebuild
+++ b/sys-apps/toybox/toybox-0.8.4.ebuild
@@ -20,9 +20,6 @@ HOMEPAGE="https://landley.net/code/toybox/"
LICENSE="BSD-2"
SLOT="0"
-# makefile is stupid
-#RESTRICT="test"
-
src_prepare() {
default
restore_config .config
@@ -31,6 +28,7 @@ src_prepare() {
src_configure() {
tc-export CC STRIP
export HOSTCC="$(tc-getBUILD_CC)"
+ # Respect CFLAGS
export OPTIMIZE="${CFLAGS}"
if [[ -f .config ]]; then
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 68a184db8ebe..5b1788940a17 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit multiprocessing savedconfig toolchain-funcs
@@ -13,16 +13,12 @@ else
KEYWORDS="~amd64 ~x86"
fi
-# makefile is stupid
-RESTRICT="test"
-
DESCRIPTION="Common linux commands in a multicall binary"
HOMEPAGE="https://landley.net/code/toybox/"
# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
src_prepare() {
default
@@ -32,7 +28,10 @@ src_prepare() {
src_configure() {
tc-export CC STRIP
export HOSTCC="$(tc-getBUILD_CC)"
- if [ -f .config ]; then
+ # Respect CFLAGS
+ export OPTIMIZE="${CFLAGS}"
+
+ if [[ -f .config ]]; then
yes "" | emake -j1 oldconfig > /dev/null
return 0
else