summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 17:38:30 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 20:43:49 -0700
commit4fba79a838cd11d82ec8f52163156b06b8983460 (patch)
tree1d035d24ebf67b106c73dfed3f1df9447092d94f /sys-apps/semodule-utils
parentsys-apps/selinux-python: update live ebuild (diff)
downloadgentoo-4fba79a838cd11d82ec8f52163156b06b8983460.tar.gz
gentoo-4fba79a838cd11d82ec8f52163156b06b8983460.tar.bz2
gentoo-4fba79a838cd11d82ec8f52163156b06b8983460.zip
sys-apps/semodule-utils: update live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/semodule-utils')
-rw-r--r--sys-apps/semodule-utils/semodule-utils-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-apps/semodule-utils/semodule-utils-9999.ebuild b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
index 13fc0d86279e..ce9f168c9c89 100644
--- a/sys-apps/semodule-utils/semodule-utils-9999.ebuild
+++ b/sys-apps/semodule-utils/semodule-utils-9999.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
-IUSE=""
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
fi
-DESCRIPTION="SELinux policy module utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
DEPEND=">=sys-libs/libsepol-${PV}:="
-
RDEPEND="${DEPEND}"
src_prepare() {