summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-11 01:05:34 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-11 01:06:44 -0500
commitddd593f1209dd01dd8307567798ad1a4b2e39be3 (patch)
tree615da5c2230ef01f69ca5a66aa28f1a789aacc6e /sys-apps/paxctld/paxctld-1.1.ebuild
parentdev-python/croniter: new package (diff)
downloadgentoo-ddd593f1209dd01dd8307567798ad1a4b2e39be3.tar.gz
gentoo-ddd593f1209dd01dd8307567798ad1a4b2e39be3.tar.bz2
gentoo-ddd593f1209dd01dd8307567798ad1a4b2e39be3.zip
sys-apps/paxctld: version bump to 1.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps/paxctld/paxctld-1.1.ebuild')
-rw-r--r--sys-apps/paxctld/paxctld-1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/paxctld/paxctld-1.1.ebuild b/sys-apps/paxctld/paxctld-1.1.ebuild
new file mode 100644
index 000000000000..765b8aa60b83
--- /dev/null
+++ b/sys-apps/paxctld/paxctld-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit systemd
+
+DESCRIPTION="PaX flags maintenance daemon"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
+ https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ # Respect Gentoo flags and don't strip
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ -e '/STRIP/d' \
+ Makefile
+}
+
+src_install() {
+ default
+
+ systemd_dounit "${S}"/rpm/${PN}.service
+}