summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 01:22:46 +0100
committerSam James <sam@gentoo.org>2023-05-31 01:23:06 +0100
commitb26d89745e01fe8f75f1d5be8905be6f287538bb (patch)
tree6f5a91749698d92fa06756f894ad824b6decdb61 /sys-apps/moar
parentsys-apps/moar: drop 1.14.0 (diff)
downloadgentoo-b26d89745e01fe8f75f1d5be8905be6f287538bb.tar.gz
gentoo-b26d89745e01fe8f75f1d5be8905be6f287538bb.tar.bz2
gentoo-b26d89745e01fe8f75f1d5be8905be6f287538bb.zip
sys-apps/moar: add 1.15.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.15.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index f2573de1b880..68e30d5e15ba 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -1,2 +1,4 @@
DIST moar-1.15.0-deps.tar.xz 4808044 BLAKE2B cd7808337af5acb2bd6cb4b9696c9d04803df033b5a1d4904418602dc629cef7c16172b0eaa57644be76a02b6727d36f767bfafba1377ea95eb827fbb4a1d34b SHA512 e51ca15137f4b5dc5ea447c200341aaeb06cd77118cd8f2fb3efca0ffc2d4199e00687f980803c4ff09c535621b58206b22bff2c944ad8786c73c3a7c886d6c6
DIST moar-1.15.0.tar.gz 2780805 BLAKE2B 6a50018596f34de7d43fcedf0155141a6cd8d5896f34a05b44cfc5180d00e17caaf46377ecc3bb273fd5e2fd4536ada94e82cc7a8788cd14b030390f22ba40a4 SHA512 deedb8bf6f28f68a1633296a32a690df109c867023980125f7550111a3cf20463980c95fbddbafb16175aa03c46f3bf6150fbe066508cedffce49dd9bf18a90c
+DIST moar-1.15.1-deps.tar.xz 4808044 BLAKE2B cd7808337af5acb2bd6cb4b9696c9d04803df033b5a1d4904418602dc629cef7c16172b0eaa57644be76a02b6727d36f767bfafba1377ea95eb827fbb4a1d34b SHA512 e51ca15137f4b5dc5ea447c200341aaeb06cd77118cd8f2fb3efca0ffc2d4199e00687f980803c4ff09c535621b58206b22bff2c944ad8786c73c3a7c886d6c6
+DIST moar-1.15.1.tar.gz 2780649 BLAKE2B 79145ae426f5ae77d73dd556521135bfad21af3841818c4092eb476a52b408da86a4ce1f4c8e43712e74be233b7fc9469788e2134c866e8bb8ba83927c7f4f2d SHA512 c58fc57f583e8051c3e1f567e9d8ad0aca45dcbfb1998d0156cb07b90bc2359d70c8fe90849f753f969980af919d9faef82cde7dedcf2aa9aeab4c080edc7752
diff --git a/sys-apps/moar/moar-1.15.1.ebuild b/sys-apps/moar/moar-1.15.1.ebuild
new file mode 100644
index 000000000000..177f577621ac
--- /dev/null
+++ b/sys-apps/moar/moar-1.15.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="!dev-lang/moarvm"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}