summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-06-30 11:11:18 -0500
committerBen Kohler <bkohler@gentoo.org>2022-06-30 11:14:36 -0500
commit3b08d25f6cb19235da2847e6da424a03ff1179c9 (patch)
treefd9c2d76d0fb73031acae42e846ff524d62128f1 /sys-apps/kmscon
parentdev-lang/dafny-bin: use insopts (diff)
downloadgentoo-3b08d25f6cb19235da2847e6da424a03ff1179c9.tar.gz
gentoo-3b08d25f6cb19235da2847e6da424a03ff1179c9.tar.bz2
gentoo-3b08d25f6cb19235da2847e6da424a03ff1179c9.zip
sys-apps/kmscon: add 9.0.0
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/kmscon')
-rw-r--r--sys-apps/kmscon/Manifest1
-rw-r--r--sys-apps/kmscon/files/kmscon-9.0.0-systemd-path-fix.patch13
-rw-r--r--sys-apps/kmscon/kmscon-9.0.0.ebuild75
3 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/kmscon/Manifest b/sys-apps/kmscon/Manifest
index abab6f35882d..e729f7c3ca1f 100644
--- a/sys-apps/kmscon/Manifest
+++ b/sys-apps/kmscon/Manifest
@@ -1,2 +1,3 @@
DIST kmscon-8_p20180906.tar.gz 1156350 BLAKE2B 52c024ca6e9652b468efb23d38cda34bf0c05e1e2bb4268435e17adb8858439ac6bf0e1783cfdd24a48fcb2dcf7c1cb20eee09aeb90db08c2e94224d01efeff7 SHA512 2ccdc5b30df6d96ac7a75d01d674b295bcdb0d445169716638a20c9884b090bbfe509e0aee79cb674a2d9b0eb18ea6284b9d4e2939cb5bf290cade4c1a02487a
DIST kmscon-8_p20220214.tar.gz 1158069 BLAKE2B a64b19da4bc57e4baed8d3822cbf7cca472614a30fe604a09c53f8ab3e024725abdad7286c6c183e7de3b24bd80e01c5141d6c7f10794b9101530832602dad4f SHA512 837026b3f9702fe487d63d665140ea9e37a39975161e86f78a4c989b18eabd3c3429a4a6ebc384790389042b014dbaaa8225a136290f9310b113b606e551f4c2
+DIST kmscon-9.0.0.tar.xz 736668 BLAKE2B a44a4b3739b1ed4a597713ca2ef7adb33f1ab7130322a419ee88517addfbf0edf01ef59f06c5626e95a7bc1708cf4cebe49d5853558aa3fedb3aa9c7c28a7dd7 SHA512 2d4bca093c40307e155c9cfa349eef433d7ab6d08f8e134a61fa9c5ccb9ad594575725371075aaf917c2a9dfb3cb3cd148296dce25065a02b3a211650cde9c3c
diff --git a/sys-apps/kmscon/files/kmscon-9.0.0-systemd-path-fix.patch b/sys-apps/kmscon/files/kmscon-9.0.0-systemd-path-fix.patch
new file mode 100644
index 000000000000..417c38b77c1f
--- /dev/null
+++ b/sys-apps/kmscon/files/kmscon-9.0.0-systemd-path-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index 4544587..f2ca004 100644
+--- a/meson.build
++++ b/meson.build
+@@ -37,7 +37,7 @@ sysconfdir = get_option('sysconfdir') / meson.project_name()
+ libexecdir = get_option('libexecdir') / meson.project_name()
+ mandir = get_option('mandir')
+ moduledir = get_option('libdir') / meson.project_name()
+-systemddir = get_option('libdir') / 'systemd'
++systemddir = '/lib/systemd'
+
+ #
+ # Required dependencies
diff --git a/sys-apps/kmscon/kmscon-9.0.0.ebuild b/sys-apps/kmscon/kmscon-9.0.0.ebuild
new file mode 100644
index 000000000000..cadf2d7c4b3f
--- /dev/null
+++ b/sys-apps/kmscon/kmscon-9.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SRC_URI="https://github.com/Aetf/kmscon/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+inherit meson flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="KMS/DRM based virtual Console Emulator"
+HOMEPAGE="https://github.com/Aetf/kmscon"
+
+LICENSE="MIT LGPL-2.1 BSD-2"
+SLOT="0"
+IUSE="debug doc +drm +fbdev +gles2 +pango pixman systemd +unicode"
+
+COMMON_DEPEND="
+ >=virtual/udev-172
+ x11-libs/libxkbcommon
+ >=dev-libs/libtsm-4.0.0:=
+ media-libs/mesa[X(+)]
+ drm? ( x11-libs/libdrm
+ >=media-libs/mesa-8.0.3[egl(+),gbm(+)] )
+ gles2? ( >=media-libs/mesa-8.0.3[gles2] )
+ systemd? ( sys-apps/systemd )
+ pango? ( x11-libs/pango dev-libs/glib:2 )
+ pixman? ( x11-libs/pixman )"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/xkeyboard-config"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+REQUIRED_USE="gles2? ( drm )"
+
+PATCHES=( "${FILESDIR}"/kmscon-9.0.0-systemd-path-fix.patch )
+
+src_prepare() {
+ default
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_configure() {
+
+ # kmscon sets -ffast-math unconditionally
+ strip-flags
+
+ local emesonargs=(
+ $(meson_feature doc docs)
+ $(meson_use debug)
+ $(meson_feature systemd multi_seat)
+ $(meson_feature fbdev video_fbdev)
+ $(meson_feature drm video_drm2d)
+ $(meson_feature drm video_drm3d)
+ $(meson_feature unicode font_unifont)
+ $(meson_feature pango font_pango)
+ -Drenderer_bbulk=enabled
+ $(meson_feature gles2 renderer_gltex)
+ $(meson_feature pixman renderer_pixman)
+ -Dsession_dummy=enabled
+ -Dsession_terminal=enabled
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ grep -e "^ERASECHAR" "${EROOT}"/etc/login.defs && \
+ ewarn "It is recommended that you comment out the ERASECHAR line in" && \
+ ewarn " /etc/login.defs for proper backspace functionality at the" && \
+ ewarn " kmscon login prompt. For details see:" && \
+ ewarn "https://github.com/dvdhrm/kmscon/issues/69#issuecomment-13827797"
+}