summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-19 09:51:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-19 09:51:05 +0100
commitb2d9afd8755a4981329a045d16017c0ae81f47ea (patch)
tree56b442ac8d411f9662c6a4ff9008dc1665dc64bb /sys-apps/help2man/help2man-1.47.3.ebuild
parentapp-text/xmlto: Bump to version 0.0.28 (diff)
downloadgentoo-b2d9afd8755a4981329a045d16017c0ae81f47ea.tar.gz
gentoo-b2d9afd8755a4981329a045d16017c0ae81f47ea.tar.bz2
gentoo-b2d9afd8755a4981329a045d16017c0ae81f47ea.zip
sys-apps/help2man: Bump to version 1.47.3
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/help2man/help2man-1.47.3.ebuild')
-rw-r--r--sys-apps/help2man/help2man-1.47.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/help2man/help2man-1.47.3.ebuild b/sys-apps/help2man/help2man-1.47.3.ebuild
new file mode 100644
index 000000000000..c9efdba10797
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.47.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND=${RDEPEND}
+
+DOCS="debian/changelog NEWS README THANKS" #385753
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ econf \
+ ac_cv_path_MSGFMT=$(type -P false) \
+ $(use_enable nls)
+}