summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-07 09:34:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-07 09:39:06 +0000
commitb8401f22eb250e5c0d5c120d4f66e35ea89cf821 (patch)
tree41e625c240ca00563f9236f8458ee14785a64124 /sys-apps/dtc
parentapp-text/pytextile: sparc stable wrt bug #711718 (diff)
downloadgentoo-b8401f22eb250e5c0d5c120d4f66e35ea89cf821.tar.gz
gentoo-b8401f22eb250e5c0d5c120d4f66e35ea89cf821.tar.bz2
gentoo-b8401f22eb250e5c0d5c120d4f66e35ea89cf821.zip
sys-apps/dtc: tweak for gcc-10, bug #706660
Pull in upstream patch 0e9225eb0dfec5 "Remove redundant YYLOC global declaration". Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/706660 Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps/dtc')
-rw-r--r--sys-apps/dtc/dtc-1.5.0.ebuild3
-rw-r--r--sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch50
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/dtc/dtc-1.5.0.ebuild b/sys-apps/dtc/dtc-1.5.0.ebuild
index d0d47ebca8e7..cbe4052e6125 100644
--- a/sys-apps/dtc/dtc-1.5.0.ebuild
+++ b/sys-apps/dtc/dtc-1.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,7 @@ DOCS="
PATCHES=(
"${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
"${FILESDIR}"/${PN}-1.5.0-fdt_check_full-visibility.patch
+ "${FILESDIR}"/${PN}-1.5.0-gcc-10.patch
)
src_prepare() {
diff --git a/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch b/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch
new file mode 100644
index 000000000000..80773bfaebbc
--- /dev/null
+++ b/sys-apps/dtc/files/dtc-1.5.0-gcc-10.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/706660
+https://git.kernel.org/pub/scm/utils/dtc/dtc.git/patch/?id=0e9225eb0dfec51def612b928d2f1836b092bc7e
+
+From 0e9225eb0dfec51def612b928d2f1836b092bc7e Mon Sep 17 00:00:00 2001
+From: Dirk Mueller <dmueller@suse.com>
+Date: Tue, 14 Jan 2020 18:53:41 +0100
+Subject: Remove redundant YYLOC global declaration
+
+gcc 10 will default to -fno-common, which causes this error at link
+time:
+
+ (.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
+
+This is because both dtc-lexer as well as dtc-parser define the same
+global symbol yyloc. Before with -fcommon those were merged into one
+defintion. The proper solution would be to to mark this as "extern",
+however that leads to:
+
+ dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
+ 26 | extern YYLTYPE yylloc;
+ | ^~~~~~
+In file included from dtc-lexer.l:24:
+dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
+ 127 | extern YYLTYPE yylloc;
+ | ^~~~~~
+cc1: all warnings being treated as errors
+
+which means the declaration is completely redundant and can just be
+dropped.
+
+Signed-off-by: Dirk Mueller <dmueller@suse.com>
+Message-Id: <20200114175341.2994-1-dmueller@suse.com>
+Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
+---
+ dtc-lexer.l | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/dtc-lexer.l
++++ b/dtc-lexer.l
+@@ -23,7 +23,6 @@ LINECOMMENT "//".*\n
+ #include "srcpos.h"
+ #include "dtc-parser.tab.h"
+
+-YYLTYPE yylloc;
+ extern bool treesource_error;
+
+ /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
+--
+cgit 1.2-0.3.lf.el7
+