summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-06-01 09:47:41 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-06-01 11:23:49 +0300
commit948452cac4bbf02003eae5279684ead0495b0e8d (patch)
treedd30bcb6fad6e60e416e99256e15f299916d293a /sys-apps/busybox
parentdev-perl/SDL: skip hanging test (diff)
downloadgentoo-948452cac4bbf02003eae5279684ead0495b0e8d.tar.gz
gentoo-948452cac4bbf02003eae5279684ead0495b0e8d.tar.bz2
gentoo-948452cac4bbf02003eae5279684ead0495b0e8d.zip
sys-apps/busybox: ignore cp -n error in postinstall
Before coreutils-9.2, cp -n (noclobber) would return success even if skipping files. Now it returns an error. See also https://debbugs.gnu.org/cgi/bugreport.cgi?bug=62572 This is used in postinstall with the purpose of not replacing already existing utilities with links to busybox, so failing here is expected. Unfortunately we cannot distinguish this from other errors. Closes: https://bugs.gentoo.org/907432 Closes: https://github.com/gentoo/gentoo/pull/31257 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.34.1-r1.ebuild6
-rw-r--r--sys-apps/busybox/busybox-1.34.1-r2.ebuild4
-rw-r--r--sys-apps/busybox/busybox-1.35.0-r1.ebuild6
-rw-r--r--sys-apps/busybox/busybox-1.35.0-r2.ebuild4
-rw-r--r--sys-apps/busybox/busybox-1.36.1.ebuild4
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild4
6 files changed, 20 insertions, 8 deletions
diff --git a/sys-apps/busybox/busybox-1.34.1-r1.ebuild b/sys-apps/busybox/busybox-1.34.1-r1.ebuild
index 130d7bd7dce9..18721b1191da 100644
--- a/sys-apps/busybox/busybox-1.34.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.34.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -348,7 +348,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-1.34.1-r2.ebuild b/sys-apps/busybox/busybox-1.34.1-r2.ebuild
index cf4da6210564..e316fec96042 100644
--- a/sys-apps/busybox/busybox-1.34.1-r2.ebuild
+++ b/sys-apps/busybox/busybox-1.34.1-r2.ebuild
@@ -355,7 +355,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-1.35.0-r1.ebuild b/sys-apps/busybox/busybox-1.35.0-r1.ebuild
index d08c6a826b69..830157ef61f4 100644
--- a/sys-apps/busybox/busybox-1.35.0-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.35.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -349,7 +349,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-1.35.0-r2.ebuild b/sys-apps/busybox/busybox-1.35.0-r2.ebuild
index 711785eae12b..b120932ad31f 100644
--- a/sys-apps/busybox/busybox-1.35.0-r2.ebuild
+++ b/sys-apps/busybox/busybox-1.35.0-r2.ebuild
@@ -356,7 +356,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-1.36.1.ebuild b/sys-apps/busybox/busybox-1.36.1.ebuild
index a9f3d85703c7..8a030a712279 100644
--- a/sys-apps/busybox/busybox-1.36.1.ebuild
+++ b/sys-apps/busybox/busybox-1.36.1.ebuild
@@ -346,7 +346,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index a9f3d85703c7..8a030a712279 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -346,7 +346,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then