summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/gle/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/gle/files')
-rw-r--r--sci-visualization/gle/files/64gle-gentoo.el6
-rw-r--r--sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch62
-rw-r--r--sci-visualization/gle/files/gle-4.2.4b-parallel.patch21
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-visualization/gle/files/64gle-gentoo.el b/sci-visualization/gle/files/64gle-gentoo.el
new file mode 100644
index 000000000000..841503ba6eec
--- /dev/null
+++ b/sci-visualization/gle/files/64gle-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; gle site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'gle-mode "gle-mode")
+(add-to-list 'auto-mode-alist '("\\.gle\\'" . gle-mode))
diff --git a/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
new file mode 100644
index 000000000000..1a0c3a4f42c5
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4b-gcc-4.7.patch
@@ -0,0 +1,62 @@
+ src/gle/gle-interface/gle-base.h | 4 ++--
+ src/gle/tokens/RefCount.h | 2 +-
+ src/gle/tokens/StringKeyHash.h | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/gle/gle-interface/gle-base.h b/src/gle/gle-interface/gle-base.h
+index 26ce8f3..686c2df 100644
+--- a/src/gle/gle-interface/gle-base.h
++++ b/src/gle/gle-interface/gle-base.h
+@@ -130,7 +130,7 @@ inline GLERefCountObject* GLE_SET_RC(GLERefCountObject* rc, GLERefCountObject* v
+
+ template <class T> class GLERCVector : public vector< GLERC<T> > {
+ public:
+- inline void add(T* elem) { push_back(GLERC<T>(elem)); }
++ inline void add(T* elem) { this->push_back(GLERC<T>(elem)); }
+ inline T* get(int i) { return (*this)[i].get(); }
+ };
+
+@@ -147,7 +147,7 @@ public:
+ }
+ void deleteAll() {
+ for (typename vector<T*>::size_type i = 0; i < vector<T*>::size(); i++) {
+- T* elem = at(i);
++ T* elem = this->at(i);
+ if (elem != NULL) delete elem;
+ }
+ }
+diff --git a/src/gle/tokens/RefCount.h b/src/gle/tokens/RefCount.h
+index eef1824..d43540b 100644
+--- a/src/gle/tokens/RefCount.h
++++ b/src/gle/tokens/RefCount.h
+@@ -125,7 +125,7 @@ public:
+ template <class T> class MutableRefCountPtr : public RefCountPtr<T> {
+ public:
+ inline RefCountPtr<T>& operator =(RefCountPtr<T> src) {
+- setPtr(src.get()); return *this;
++ this->setPtr(src.get()); return *this;
+ };
+ };
+
+diff --git a/src/gle/tokens/StringKeyHash.h b/src/gle/tokens/StringKeyHash.h
+index 7db46c3..0966676 100644
+--- a/src/gle/tokens/StringKeyHash.h
++++ b/src/gle/tokens/StringKeyHash.h
+@@ -254,7 +254,7 @@ public:
+ return i->second;
+ } else {
+ ElemType nelem(key);
+- insert(StringKeyPair<ElemType>(key, nelem));
++ this->insert(StringKeyPair<ElemType>(key, nelem));
+ return nelem;
+ }
+ }
+@@ -309,7 +309,7 @@ public:
+ }
+
+ void add_item(int key, ElemType elem) {
+- insert(IntKeyPair<ElemType>(key, elem));
++ this->insert(IntKeyPair<ElemType>(key, elem));
+ }
+ };
+
diff --git a/sci-visualization/gle/files/gle-4.2.4b-parallel.patch b/sci-visualization/gle/files/gle-4.2.4b-parallel.patch
new file mode 100644
index 000000000000..1eff8c067102
--- /dev/null
+++ b/sci-visualization/gle/files/gle-4.2.4b-parallel.patch
@@ -0,0 +1,21 @@
+--- src/gui/MakefileAC.in.orig 2010-01-06 20:10:04.000000000 +0000
++++ src/gui/MakefileAC.in 2010-01-06 20:21:15.000000000 +0000
+@@ -84,14 +84,14 @@
+ qmake:
+ $(QMAKE_PROG) $(QMAKE_OPTS)
+
+-domake:
+- $(MAKE_PROG)
++domake: Makefile
++ $(MAKE)
+
+-repmake:
++repmake: Makefile
+ perl ../../platform/autopackage/qt-replace.pl Makefile
+
+ doclean:
+- -$(MAKE_PROG) clean
++ -$(MAKE) clean
+ -@$(RM) qgle install_qgle_name_mac Makefile
+ -@$(RMDIR) moc
+ -@$(RMDIR) objects