summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/yacas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/Manifest3
-rw-r--r--sci-mathematics/yacas/files/yacas-1.3.4-java-version.patch29
-rw-r--r--sci-mathematics/yacas/metadata.xml16
-rw-r--r--sci-mathematics/yacas/yacas-1.3.2.ebuild46
-rw-r--r--sci-mathematics/yacas/yacas-1.3.3.ebuild46
-rw-r--r--sci-mathematics/yacas/yacas-1.3.4.ebuild55
6 files changed, 195 insertions, 0 deletions
diff --git a/sci-mathematics/yacas/Manifest b/sci-mathematics/yacas/Manifest
new file mode 100644
index 000000000000..07e576e073f9
--- /dev/null
+++ b/sci-mathematics/yacas/Manifest
@@ -0,0 +1,3 @@
+DIST yacas-1.3.2.tar.gz 1292706 SHA256 82c7dc0de492b4290633e6abf18d35a2ec03117e6ea3e0f9418e6e85372c030e
+DIST yacas-1.3.3.tar.gz 1296777 SHA256 6c73c653c5e13567510888800a68c14d231b1ef4f2b33193a158b8caec142141 SHA512 a0c60f78a0d3f19d5fa820bdf62b2ae25ece00f985422a17a56f091ff240b74811af1c1480c24eff5dcb5cb021aa9709664e929913a33f411e6d2b64f37d3c70 WHIRLPOOL f1334fd7cd191b1e9448efaed0542f338f35cf769ef2c6e8ca43ab0a75994aa09286fb6e5688b78927980ba4967093f971be33785f4a3d92a377532dd5e09a34
+DIST yacas-1.3.4.tar.gz 1582029 SHA256 11de62f7ff014bc8a14c5f48f9c34107509506636b4701999413d0cb4dac5c69 SHA512 9ec26e2c9d5355aa124a17f7dc4164c224fed880481ebd0a672c500dae9e066e37700cbd5bf896686f713a7615a58dde7be7a7a843ab236bfd0921774dc50a43 WHIRLPOOL 1d1028083ebdb1bb4d25346200b76ab76e807174886179194bc4fffb582771861535e738d47635c5df45e21edf942458dc58221cfa7826a53df0119b71c6dade
diff --git a/sci-mathematics/yacas/files/yacas-1.3.4-java-version.patch b/sci-mathematics/yacas/files/yacas-1.3.4-java-version.patch
new file mode 100644
index 000000000000..7f6ab2da5144
--- /dev/null
+++ b/sci-mathematics/yacas/files/yacas-1.3.4-java-version.patch
@@ -0,0 +1,29 @@
+--- JavaYacas/dumpversion.cpp.orig 2014-06-09 12:10:15.095959491 -0700
++++ JavaYacas/dumpversion.cpp 2014-06-09 12:11:09.565339056 -0700
+@@ -1,11 +1,11 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include "version.h"
++#include "yacas/yacas_version.h"
+
+ int main(int argc, char** argv)
+ {
+ printf("package net.sf.yacas;\n");
+- printf("class CVersion { static String VERSION = \"%s\"; }\n", VERSION);
++ printf("class CVersion { static String VERSION = \"%s\"; }\n", YACAS_VERSION);
+ return 0;
+ }
+
+--- JavaYacas/makefile.yacas.orig 2014-06-09 12:11:47.516603467 -0700
++++ JavaYacas/makefile.yacas 2014-06-09 15:03:17.329987079 -0700
+@@ -32,8 +32,8 @@
+ .java.class:
+ $(JAVAC) $(JAVACFLAGS) $*.java
+
+-net/sf/yacas/CVersion.java: ../src/version.h dumpversion.cpp
+- $(CXX) $(CXXFLAGS) -I ../src dumpversion.cpp -o dumpversion
++net/sf/yacas/CVersion.java: ../include/yacas/yacas_version.h dumpversion.cpp
++ $(CXX) $(CXXFLAGS) -I ../include dumpversion.cpp -o dumpversion
+ ./dumpversion > net/sf/yacas/CVersion.java
+
+
diff --git a/sci-mathematics/yacas/metadata.xml b/sci-mathematics/yacas/metadata.xml
new file mode 100644
index 000000000000..e992686a974a
--- /dev/null
+++ b/sci-mathematics/yacas/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+ Yacas (Yet Another Computer Algebra System) is a small and highly
+ flexible general-purpose computer algebra language. The syntax uses a
+ infix-operator grammar parser. The distribution contains a small
+ library of mathematical functions, but its real strength is in the
+ language in which you can easily write your own symbolic manipulation
+ algorithms.
+</longdescription>
+<use>
+ <flag name="server">Build the network server version</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-mathematics/yacas/yacas-1.3.2.ebuild b/sci-mathematics/yacas/yacas-1.3.2.ebuild
new file mode 100644
index 000000000000..6b284a29ae52
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils java-pkg-opt-2
+
+DESCRIPTION="General purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc java server"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
+
+src_configure() {
+ econf \
+ $(use_enable doc html-doc) \
+ $(use_enable server) \
+ --with-html-dir="/usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ # -j1 because of file generation dependence
+ emake -j1 -f makefile.yacas
+ fi
+}
+
+src_install() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
+ insinto /usr/share/${PN}
+ doins hints.txt yacasconsole.html
+ fi
+}
diff --git a/sci-mathematics/yacas/yacas-1.3.3.ebuild b/sci-mathematics/yacas/yacas-1.3.3.ebuild
new file mode 100644
index 000000000000..42c15e4e0118
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.3.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils java-pkg-opt-2
+
+DESCRIPTION="General purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc java server"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
+
+src_configure() {
+ econf \
+ $(use_enable doc html-doc) \
+ $(use_enable server) \
+ --with-html-dir="/usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ # -j1 because of file generation dependence
+ emake -j1 -f makefile.yacas
+ fi
+}
+
+src_install() {
+ default
+ if use java; then
+ cd JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
+ insinto /usr/share/${PN}
+ doins hints.txt yacasconsole.html
+ fi
+}
diff --git a/sci-mathematics/yacas/yacas-1.3.4.ebuild b/sci-mathematics/yacas/yacas-1.3.4.ebuild
new file mode 100644
index 000000000000..dd401974d862
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.3.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit java-pkg-opt-2 autotools-utils
+
+DESCRIPTION="General purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0/1"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc java static-libs server"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-java-version.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-html-dir="/usr/share/doc/${PF}/html"
+ $(use_enable doc html-doc)
+ $(use_enable server)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+ if use java; then
+ cd "${BUILD_DIR}"/JavaYacas || die
+ # -j1 because of file generation dependence
+ emake -j1 -f makefile.yacas
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use java; then
+ cd "${BUILD_DIR}"/JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
+ insinto /usr/share/${PN}
+ doins "${S}"/JavaYacas/{hints.txt,yacasconsole.html}
+ fi
+}