summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-16 17:43:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-12-16 17:44:15 -0500
commit5121731dc7e97afd304d04c1f11239174c78ffc5 (patch)
tree4a90211d5ba7b86d4445dde0b31444698321b8fa /sci-mathematics/pari-data/pari-data-20191216.ebuild
parentwww-client/opera-developer: Version 67.0.3536.0 (diff)
downloadgentoo-5121731dc7e97afd304d04c1f11239174c78ffc5.tar.gz
gentoo-5121731dc7e97afd304d04c1f11239174c78ffc5.tar.bz2
gentoo-5121731dc7e97afd304d04c1f11239174c78ffc5.zip
sci-mathematics/pari-data: new version to force mirror of new tarballs.
There are new versions of these databases, but upstream modifies the (unversioned) tarballs for them in-place when that happens. We tag the distfiles with the package version, however, so this new version should force new copies of everything to be mirrored. In addition, I've used https in HOMEPAGE and SRC_URI, and have updated the ebuild from EAPI=4 to EAPI=7. Closes: https://bugs.gentoo.org/703146 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/pari-data/pari-data-20191216.ebuild')
-rw-r--r--sci-mathematics/pari-data/pari-data-20191216.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/pari-data/pari-data-20191216.ebuild b/sci-mathematics/pari-data/pari-data-20191216.ebuild
new file mode 100644
index 000000000000..f41ab40d38c4
--- /dev/null
+++ b/sci-mathematics/pari-data/pari-data-20191216.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Additional dataset packages for PARI"
+HOMEPAGE="https://pari.math.u-bordeaux.fr/packages.html"
+
+# Beware, upstream occasionally updates these tarballs in-place
+# with new versions. When that happens, we need to bump this
+# package to a new version so that any mirrored tarballs will
+# get re-fetched to a new name.
+SRC_URI=""
+for p in elldata galpol seadata nftables galdata; do
+ SRC_URI+="https://pari.math.u-bordeaux.fr/pub/pari/packages/${p}.tgz \
+ -> ${p}-${PV}.tgz "
+done
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE=""
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pari
+ doins -r data/* nftables
+}