summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2021-01-14 16:44:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-03 09:09:48 +0200
commitb5577d6880dfe204cbe3eb42683143ad8f888c19 (patch)
treec606323a0546ba38853463f8d2b003e2d361634f /sci-mathematics/gimps
parentwww-misc/buku: fix test failures with >=hypothesis-6 (diff)
downloadgentoo-b5577d6880dfe204cbe3eb42683143ad8f888c19.tar.gz
gentoo-b5577d6880dfe204cbe3eb42683143ad8f888c19.tar.bz2
gentoo-b5577d6880dfe204cbe3eb42683143ad8f888c19.zip
sci-mathematics/gimps: Version bump to version 30.4 build 8
Closes: https://bugs.gentoo.org/764350 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18983 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-mathematics/gimps')
-rw-r--r--sci-mathematics/gimps/Manifest1
-rw-r--r--sci-mathematics/gimps/gimps-30.4.8.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 48c8724673d7..482bc0397424 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -1,2 +1,3 @@
DIST p95v303b6.linux32.tar.gz 5702312 BLAKE2B 728c8b8e7e2b5187dc8126bccc5e2c165fbfbc0900d6c35517cd21b78e5292df143641e3766cc0146918062039b1eecab568f9b278f64b1b9197ee2f775603b9 SHA512 3e06fb77be07334949ece3ae152bdf5491f0b7f8e33e0e8ed2af3c34332841975a9514d1993ed2355abfa4e09f93e42093d02f96dc30c3471ae9f974cc2de11a
DIST p95v303b6.linux64.tar.gz 7046127 BLAKE2B 9cde9c2670203071cfc463434a47c8123064cb232bfeb25d8767cad2c25ea75b395e2ec135b7b4a6dc9616e9d6b05ead371e1083274a82468f62a0e1de93c98f SHA512 6d6ded9a1724993d42adee28d400b0337835c52a4ce42271e62efb37134adfc6f017f55475860fbc1224e377a227ef8547b8852a35c082c37e996f4a1c1b570c
+DIST p95v304b8.linux64.tar.gz 7163830 BLAKE2B 248a2d5343e25fd9153294bf8e84a59253f28feb7ede8147b73d08077a107c63e0209adfd48845f64ce51e06cd32aec966e4a36ef20e1c30df4f0be0d4978d86 SHA512 b4f89c89714e738f468f085ac9902db0b62cad720a926f91cf8dbe25153e41a207e1c10a5d74136976994b9d1ca312653e6b91536ed3d57bc44760055143f4b3
diff --git a/sci-mathematics/gimps/gimps-30.4.8.ebuild b/sci-mathematics/gimps/gimps-30.4.8.ebuild
new file mode 100644
index 000000000000..8e7b9650b136
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-30.4.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="https://www.mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(ver_rs 2 'b' )
+
+SRC_URI="
+ amd64? ( https://www.mersenne.org/ftp_root/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ "
+
+SLOT="0"
+LICENSE="GIMPS"
+RESTRICT="mirror bindist"
+KEYWORDS="-* ~amd64"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I}
+ keepdir /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}