summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/agda-lib-ffi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/agda-lib-ffi')
-rw-r--r--sci-mathematics/agda-lib-ffi/Manifest2
-rw-r--r--sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2-r2.ebuild31
-rw-r--r--sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2.ebuild34
-rw-r--r--sci-mathematics/agda-lib-ffi/metadata.xml14
4 files changed, 81 insertions, 0 deletions
diff --git a/sci-mathematics/agda-lib-ffi/Manifest b/sci-mathematics/agda-lib-ffi/Manifest
new file mode 100644
index 000000000000..d8103164a7ee
--- /dev/null
+++ b/sci-mathematics/agda-lib-ffi/Manifest
@@ -0,0 +1,2 @@
+DIST agda-stdlib-2.4.2.3.tar.gz 252558 SHA256 bb444fb35096be277c07aa27652c24509449fee9188325bb13eaac68b91eca7d SHA512 d503fc2abd18ab8c367a1947301e0302a6ff9fcbb6376a01f016aa2ab7a9a967e5adb96c5013db1892f4acd9fab62bead11c58c4d443784aff1e42ee4ffd4aa9 WHIRLPOOL 829e5613f2e03cda80608ef0899db413c98a505c9ba595d3aacd12171fc2e30e18e72365770a85655c7670fc5d45103c3b186d2bf8d9697aebae15bc9f40feaf
+DIST lib-0.7.tar.gz 226400 SHA256 631a33e8e27ead32c85cc92a0a85849744d3b2960ef9675736d54288267ed2fa SHA512 557aa7b9b143f2e4a2249881a98c753035962bc5d9222241e6b4fe86aab8642986aa9db7ca6fc2b2da8486f9294ff30c4c2edfa0222ba95d9216ed2d0e00c114 WHIRLPOOL f51ba5c3430e9a8a11d8eacab3b6121c730e4a437286b88f743fc2521bf1941a889d5274dd4aa7f4fe283595b5ac29a8a35735d873eedc94505455178d167536
diff --git a/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2-r2.ebuild b/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2-r2.ebuild
new file mode 100644
index 000000000000..2774fd4407dd
--- /dev/null
+++ b/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5
+
+CABAL_FEATURES="lib"
+inherit haskell-cabal
+
+AGDA_PN="agda-stdlib"
+AGDA_PV="2.4.2.3"
+AGDA_P="${AGDA_PN}-${AGDA_PV}"
+
+DESCRIPTION="Auxiliary Haskell code used by Agda's standard library"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="https://github.com/agda/${AGDA_PN}/archive/${AGDA_PV}.tar.gz -> ${AGDA_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${AGDA_P}/ffi"
diff --git a/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2.ebuild b/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2.ebuild
new file mode 100644
index 000000000000..ba329a2a9dec
--- /dev/null
+++ b/sci-mathematics/agda-lib-ffi/agda-lib-ffi-0.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5
+
+CABAL_FEATURES="lib"
+inherit haskell-cabal
+
+AGDA_P="lib-0.7"
+
+DESCRIPTION="Auxiliary Haskell code used by Agda's standard library"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://www.cse.chalmers.se/~nad/software/${AGDA_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${AGDA_P}/ffi"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 3.0.3.1 && < 4.7' 'base >= 3.0.3.1'
+}
diff --git a/sci-mathematics/agda-lib-ffi/metadata.xml b/sci-mathematics/agda-lib-ffi/metadata.xml
new file mode 100644
index 000000000000..1439b435aad6
--- /dev/null
+++ b/sci-mathematics/agda-lib-ffi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Auxiliary Haskell code used by Agda's standard library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">agda/agda-stdlib</remote-id>
+ </upstream>
+</pkgmetadata>