summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 11:42:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 11:42:03 +0200
commitb9ce0bb059a90dc796135b4fee18c1044d338775 (patch)
tree375bf812ead7af7630dbd692abbdc30cb81c0389 /sci-libs
parentapp-eselect/eselect-vi: x86 stable wrt bug #733362 (diff)
downloadgentoo-b9ce0bb059a90dc796135b4fee18c1044d338775.tar.gz
gentoo-b9ce0bb059a90dc796135b4fee18c1044d338775.tar.bz2
gentoo-b9ce0bb059a90dc796135b4fee18c1044d338775.zip
sci-libs/nlopt: Drop 2.4.2-r2 and 2.6.2 (r0)
Closes: https://bugs.gentoo.org/724640 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/Manifest1
-rw-r--r--sci-libs/nlopt/nlopt-2.4.2-r2.ebuild118
-rw-r--r--sci-libs/nlopt/nlopt-2.6.2.ebuild110
3 files changed, 0 insertions, 229 deletions
diff --git a/sci-libs/nlopt/Manifest b/sci-libs/nlopt/Manifest
index 763315e9b520..a4d07e389b10 100644
--- a/sci-libs/nlopt/Manifest
+++ b/sci-libs/nlopt/Manifest
@@ -1,2 +1 @@
-DIST nlopt-2.4.2.tar.gz 2361992 BLAKE2B c1c9f533c7e7b3bb61e81343ebd26b87e05434fdbea1f347fc5f6a6c10160289ce105a51c6540296f3f1d122d31b415452da49b84516cd13fabc73372e4cfd0e SHA512 136aacc00a69f77e8a7ce5dc26a5f3f027bc8c01b97aa1f43919462e0a412154eabfb01be258e082dffe61f9b554bb2bfbb550a7b82c7c77c7b22874a64a9703
DIST nlopt-2.6.2.tar.gz 2040229 BLAKE2B f1f4124de574600ddbef8a885bbdd3a4f57b469b2f958ce94bbc831cf9bfa8a845e438fccfe4ab219a73a5675b8d880f6d49e0e7cbe9d0966777b0d2344521d4 SHA512 61e5c01140a57c0ad2a0acd82ad50dce1b5679dc281e55cbbc332e876b19a689013100617545a42b721d8c487df37d6ccd67859171243433fe29468f259b556b
diff --git a/sci-libs/nlopt/nlopt-2.4.2-r2.ebuild b/sci-libs/nlopt/nlopt-2.4.2-r2.ebuild
deleted file mode 100644
index 5a937cd80edd..000000000000
--- a/sci-libs/nlopt/nlopt-2.4.2-r2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-AUTOTOOLS_AUTORECONF=1
-
-inherit python-r1 autotools-utils
-
-DESCRIPTION="Non-linear optimization library"
-HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
-SRC_URI="http://ab-initio.mit.edu/nlopt/${P}.tar.gz"
-
-LICENSE="LGPL-2.1 MIT"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="cxx guile octave python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- guile? ( dev-scheme/guile:* )
- octave? ( sci-mathematics/octave )
- python? (
- ${PYTHON_DEPS}
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.3-pkgconfig.patch
- "${FILESDIR}"/${PN}-2.3-as-needed.patch
- "${FILESDIR}"/${P}-fix-dynamic-underlinking.patch
-)
-
-src_prepare() {
- # fix #569996 due to renaming of Octave_map class
- has_version ">=sci-mathematics/octave-4.0" && \
- epatch "${FILESDIR}/${P}-octave-4-map.patch"
- autotools-utils_src_prepare
- use cxx && BUILD_CXX="${S}_cxx"
- use python && python_copy_sources
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with octave)
- )
- if use octave; then
- export OCT_INSTALL_DIR="$(octave-config -p LOCALOCTFILEDIR)"
- export M_INSTALL_DIR="$(octave-config -p LOCALFCNFILEDIR)"
- else
- export MKOCTFILE=None
- fi
-
- myeconfargs+=(
- $(use_with guile)
- )
-
- if use python; then
- python_foreach_impl run_in_build_dir autotools-utils_src_configure
- else
- autotools-utils_src_configure
- fi
-
- if use cxx; then
- myeconfargs+=( --with-cxx --without-octave --without-python )
- BUILD_DIR="${BUILD_CXX}" autotools-utils_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir autotools-utils_src_compile
- else
- autotools-utils_src_compile
- fi
- use cxx && BUILD_DIR="${BUILD_CXX}" autotools-utils_src_compile
- #-C "${BUILD_DIR}_cxx"
-}
-
-src_test() {
- do_test() {
- local a f
- cd "${BUILD_DIR}"/test
- for a in {1..7}; do
- for f in {5..9}; do
- ./testopt -a $a -o $f || die "algorithm $a function $f failed"
- done
- done
- }
- if use python; then
- python_foreach_impl run_in_build_dir do_test
- else
- do_test
- fi
- cd "${BUILD_CXX}"/test
- for a in {1..9}; do
- for f in {5..9}; do
- ./testopt -a $a -o $f || die "algorithm $a function $f failed"
- done
- done
-}
-
-src_install() {
- # build cxx first so the c lib overwrites the pc file
- use cxx && BUILD_DIR="${BUILD_CXX}" autotools-utils_src_install
- if use python; then
- python_foreach_impl run_in_build_dir autotools-utils_src_install
- else
- autotools-utils_src_install
- fi
- local r
- for r in */README; do newdoc ${r} README.$(dirname ${r}); done
-}
diff --git a/sci-libs/nlopt/nlopt-2.6.2.ebuild b/sci-libs/nlopt/nlopt-2.6.2.ebuild
deleted file mode 100644
index 21c2ada3624a..000000000000
--- a/sci-libs/nlopt/nlopt-2.6.2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
-
-inherit python-r1 cmake fortran-2
-
-DESCRIPTION="Non-linear optimization library"
-HOMEPAGE="https://ab-initio.mit.edu/nlopt/"
-SRC_URI="https://github.com/stevengj/nlopt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1 MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="cxx guile octave python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- guile? ( dev-scheme/guile:* )
- octave? ( sci-mathematics/octave )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/numpy-python2[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' -3)
- )
- "
-DEPEND="
- ${RDEPEND}
- python? ( dev-lang/swig )
- "
-
-src_prepare() {
- cmake_src_prepare
- use python && python_copy_sources
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNLOPT_CXX=$(usex cxx)
- -DNLOPT_FORTRAN=$(usex test)
- -DNLOPT_GUILE=$(usex guile)
- -DNLOPT_OCTAVE=$(usex octave)
- -DNLOPT_PYTHON=$(usex python)
- -DNLOPT_SWIG=$(usex python)
- -DNLOPT_TESTS=$(usex test)
- )
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_configure
- else
- cmake_src_configure
- fi
- if use static-libs; then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- )
- BUILD_DIR="${S}_static-libs" run_in_build_dir cmake_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir cmake_src_compile
- else
- cmake_src_compile
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir cmake_src_compile
- fi
-}
-
-src_test() {
- do_test() {
- local a f
- cd "${BUILD_DIR}"/test
- for a in {1..$(usex cxx 9 7)}; do
- for f in {5..9}; do
- ./testopt -a $a -o $f || die "algorithm $a function $f failed"
- done
- done
- }
- if use python; then
- python_foreach_impl run_in_build_dir do_test
- else
- do_test
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir do_test
- fi
-}
-
-nlopt_install() {
- cmake_src_install
- python_optimize
-}
-
-src_install() {
- if use python; then
- python_foreach_impl run_in_build_dir nlopt_install
- else
- cmake_src_install
- fi
- if use static-libs; then
- BUILD_DIR="${S}_static-libs" run_in_build_dir dolib.a libnlopt.a
- fi
- local r
- for r in */README; do newdoc ${r} README.$(dirname ${r}); done
-}