summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/tnt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/tnt')
-rw-r--r--sci-libs/tnt/Manifest3
-rw-r--r--sci-libs/tnt/metadata.xml14
-rw-r--r--sci-libs/tnt/tnt-1.2.6.ebuild32
-rw-r--r--sci-libs/tnt/tnt-3.0.12.ebuild29
4 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/tnt/Manifest b/sci-libs/tnt/Manifest
new file mode 100644
index 000000000000..a5b07731205e
--- /dev/null
+++ b/sci-libs/tnt/Manifest
@@ -0,0 +1,3 @@
+DIST tnt120doc.zip 115063 SHA256 a3ca1327815c79cf9c12d432120d2cb2100748c18aac55e58338b8b8e56116c8
+DIST tnt126.zip 28784 SHA256 93c7cdd116a6faeb679890a52d5b513055388c7faaac74beea570f8f2edbd7e4
+DIST tnt_3_0_12.zip 50166 SHA256 479609bbc249e91c00392597fc48387fed8431471615c02826a8a0545673f3af SHA512 3be00d37880ffc191022db13993c3946e913e92409cef1ff5f53b74cab5ea09782d131056d89bcbd0990939967b5d93ebe93e8a7db956be2fb9e8a7356dafbfd WHIRLPOOL 10050d4eb1869e74779bc3aeee0000c1847e89cbb42f480fc479c280657d734c892429245d5ff271785dd656778c2c3bc0a762b9c92b137f60bd5ea6c094a89f
diff --git a/sci-libs/tnt/metadata.xml b/sci-libs/tnt/metadata.xml
new file mode 100644
index 000000000000..9ccc7507adaa
--- /dev/null
+++ b/sci-libs/tnt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Template Numerical Toolkit (TNT) is a collection of interfaces and
+ reference implementations of numerical objects useful for scientific
+ computing in C++. The toolkit defines interfaces for basic data
+ structures, such as multidimensional arrays and sparse matrices, commonly
+ used in numerical applications. The goal of this package is to provide
+ reusable software components that address many of the portability and
+ maintenance problems with C++ codes.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/tnt/tnt-1.2.6.ebuild b/sci-libs/tnt/tnt-1.2.6.ebuild
new file mode 100644
index 000000000000..ee0bb59337cf
--- /dev/null
+++ b/sci-libs/tnt/tnt-1.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MYP="${PN}$(replace_all_version_separators '')"
+DOCPV=120
+
+DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
+ doc? ( http://math.nist.gov/tnt/${PN}${DOCPV}doc.zip )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h
+ use doc && dohtml html/*
+}
diff --git a/sci-libs/tnt/tnt-3.0.12.ebuild b/sci-libs/tnt/tnt-3.0.12.ebuild
new file mode 100644
index 000000000000..3be46d9b8c83
--- /dev/null
+++ b/sci-libs/tnt/tnt-3.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MYP="${PN}_$(replace_all_version_separators '_')"
+
+DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h
+}