summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/nemesis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/nemesis')
-rw-r--r--sci-libs/nemesis/Manifest2
-rw-r--r--sci-libs/nemesis/files/nemesis-5.22b-multilib.patch57
-rw-r--r--sci-libs/nemesis/metadata.xml20
-rw-r--r--sci-libs/nemesis/nemesis-5.22b.ebuild47
-rw-r--r--sci-libs/nemesis/nemesis-5.24.ebuild47
5 files changed, 173 insertions, 0 deletions
diff --git a/sci-libs/nemesis/Manifest b/sci-libs/nemesis/Manifest
new file mode 100644
index 000000000000..3bd6a0d6f1fc
--- /dev/null
+++ b/sci-libs/nemesis/Manifest
@@ -0,0 +1,2 @@
+DIST exodus-5.22b.tar.gz 4693236 SHA256 6781b96039af030a98ddb893c40db06959b4843b6e2961c770b5d64d90241265 SHA512 04364b473d074c8bff194c63ed5ef78cb163ccc72a8dd196803646e8a8fe0faf25f9fd9a68d6df0ee821b9a84341b6aeabcc816b476fb3f7befe1e482a9455b7 WHIRLPOOL a95c98db2c6d825602618acaeced503bc1b9e312b6a4968011bd663d4c036976b4f5bf3fd45ceec0f31d3bca8e9a8cb6d53fd2d1b33ab25ec9e0993436abc7c6
+DIST exodus-5.24.tar.bz2 4252980 SHA256 c16a70c0572341c7e680f8d6420c79e1fd744ba717dc4f7e023f7421c636515d SHA512 d31cf17d2112b625259a70a7f73609323b94a3eed77be3b09961e67518d1b8caf82617a18f8c651fa6549988aa9a02455aea04402463b4fb7e66dd4e15b7e87e WHIRLPOOL 5a622fce123d55187c0895934db76c2cfb3ab2e83e13d6f5b6655c388e7cac1107acaa786b75be5275de7398035a5604d0be2975c78da05edbdaa4f8efbf9513
diff --git a/sci-libs/nemesis/files/nemesis-5.22b-multilib.patch b/sci-libs/nemesis/files/nemesis-5.22b-multilib.patch
new file mode 100644
index 000000000000..b99add01ea56
--- /dev/null
+++ b/sci-libs/nemesis/files/nemesis-5.22b-multilib.patch
@@ -0,0 +1,57 @@
+ nemesis/CMakeLists.txt | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/nemesis/CMakeLists.txt b/nemesis/CMakeLists.txt
+index 64aff5d..bed5ede 100644
+--- a/nemesis/CMakeLists.txt
++++ b/nemesis/CMakeLists.txt
+@@ -19,7 +19,7 @@ find_path( NETCDF_INCLUDE_DIR netcdf.h
+ find_library( NETCDF_LIBRARY netcdf
+ $ENV{ACCESS}/lib/shared
+ $ENV{ACCESS}/lib
+- $ENV{NETCDF_DIR}/lib
++ $ENV{NETCDF_DIR}/${CMAKE_INSTALL_LIBDIR}
+ $ENV{NETCDF_DIR}/libsrc/.libs
+ )
+
+@@ -29,16 +29,17 @@ find_program (NETCDF_NCDUMP ncdump
+ $ENV{NETCDF_DIR}/ncdump
+ )
+
+-find_library( EXODUS_LIBRARY exodus
++find_library( EXODUS_LIBRARY exoIIv2c
+ $ENV{ACCESS}/lib/shared
+ $ENV{ACCESS}/lib
++ $ENV{EXODUS_DIR}/${CMAKE_INSTALL_LIBDIR}
+ )
+
+ # Hack for HDF5
+ find_library( HDF5_LIBRARY hdf5
+ $ENV{ACCESS}/lib/shared
+ $ENV{ACCESS}/lib
+- $ENV{NETCDF_DIR}/lib
++ $ENV{NETCDF_DIR}/${CMAKE_INSTALL_LIBDIR}
+ $ENV{NETCDF_DIR}/libsrc/.libs
+ /usr/local/hdf5/lib
+ )
+@@ -46,7 +47,7 @@ find_library( HDF5_LIBRARY hdf5
+ find_library( HDF5HL_LIBRARY hdf5_hl
+ $ENV{ACCESS}/lib/shared
+ $ENV{ACCESS}/lib
+- $ENV{NETCDF_DIR}/lib
++ $ENV{NETCDF_DIR}/${CMAKE_INSTALL_LIBDIR}
+ $ENV{NETCDF_DIR}/libsrc/.libs
+ /usr/local/hdf5/lib
+ )
+@@ -79,8 +80,8 @@ ADD_EXECUTABLE(ne_test ne_ctest_wrap.c)
+ TARGET_LINK_LIBRARIES( ne_test nemesis ${EXODUS_LIBRARY} ${NETCDF_LIBRARY} ${HDF5HL_LIBRARY} ${HDF5_LIBRARY} ${Z_LIBRARY} ${MATH_LIBRARY})
+
+ INSTALL(TARGETS nemesis
+- RUNTIME DESTINATION lib COMPONENT Runtime
+- LIBRARY DESTINATION lib COMPONENT Runtime
+- ARCHIVE DESTINATION lib COMPONENT Development)
++ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Runtime
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Runtime
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development)
+ INSTALL(FILES ${HEADERS} DESTINATION include COMPONENT Development)
+
diff --git a/sci-libs/nemesis/metadata.xml b/sci-libs/nemesis/metadata.xml
new file mode 100644
index 000000000000..ae80af7a02ed
--- /dev/null
+++ b/sci-libs/nemesis/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+NEMESIS is an enhancement to the EXODUSII finite element database
+model used to store and retrieve data for unstructured parallel finite
+element analyses. NEMESIS adds data structures which facilitate the
+partitioning of a scalar (standard serial) EXODUSII file onto parallel
+disk systems found on many parallel computers. Since the NEMESIS
+application programming interface (API) can be used to append
+information to an existing EXODUSII database, any existing software
+that reads EXODUSII files can be used on files which contain NEMESIS
+information. The NEMESIS information is written and read via C or C++
+callable functions which compromise the NEMESIS I API.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">exodusii</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/nemesis/nemesis-5.22b.ebuild b/sci-libs/nemesis/nemesis-5.22b.ebuild
new file mode 100644
index 000000000000..abe21cb50e81
--- /dev/null
+++ b/sci-libs/nemesis/nemesis-5.22b.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils multilib
+
+MY_PN="exodus"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enhancement to the EXODUSII finite element database model"
+HOMEPAGE="http://sourceforge.net/projects/exodusii/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+DEPEND="
+ sci-libs/exodusii
+ sci-libs/netcdf"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-multilib.patch )
+
+src_prepare() {
+ find ../exodus -delete || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ -DNETCDF_DIR="${EPREFIX}/usr/"
+ -DEXODUS_DIR="${EPREFIX}/usr/"
+ $(cmake-utils_use !static-libs BUILD_SHARED_LIBS)
+ $(cmake-utils_use test BUILD_TESTING)"
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/ne_test || die
+}
diff --git a/sci-libs/nemesis/nemesis-5.24.ebuild b/sci-libs/nemesis/nemesis-5.24.ebuild
new file mode 100644
index 000000000000..8b2dfaac39a0
--- /dev/null
+++ b/sci-libs/nemesis/nemesis-5.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+MY_PN="exodus"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enhancement to the EXODUSII finite element database model"
+HOMEPAGE="http://sourceforge.net/projects/exodusii/"
+SRC_URI="mirror://sourceforge/project/${MY_PN}ii/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+DEPEND="
+ sci-libs/exodusii
+ sci-libs/netcdf"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}/${PN}
+
+PATCHES=( "${FILESDIR}"/${PN}-5.22b-multilib.patch )
+
+src_prepare() {
+ find ../exodus -delete || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ -DNETCDF_DIR="${EPREFIX}/usr/"
+ -DEXODUS_DIR="${EPREFIX}/usr/"
+ $(cmake-utils_use !static-libs BUILD_SHARED_LIBS)
+ $(cmake-utils_use test BUILD_TESTING)"
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/ne_test || die
+}