summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-11 18:55:14 +0100
committerSam James <sam@gentoo.org>2024-06-11 18:55:20 +0100
commit0c2c5e8a704527b0d86548796f074b26bf339cda (patch)
treeffd0b3f90b847963e02e1854cbb048d9c8709343 /sci-libs/libsigrok/libsigrok-9999.ebuild
parentdev-python/pygobject: enable py3.13 (diff)
downloadgentoo-0c2c5e8a704527b0d86548796f074b26bf339cda.tar.gz
gentoo-0c2c5e8a704527b0d86548796f074b26bf339cda.tar.bz2
gentoo-0c2c5e8a704527b0d86548796f074b26bf339cda.zip
sci-libs/libsigrok: enable py3.13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/libsigrok/libsigrok-9999.ebuild')
-rw-r--r--sci-libs/libsigrok/libsigrok-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/sci-libs/libsigrok/libsigrok-9999.ebuild b/sci-libs/libsigrok/libsigrok-9999.ebuild
index b0fe1e16dc1d..589e3d9a56dd 100644
--- a/sci-libs/libsigrok/libsigrok-9999.ebuild
+++ b/sci-libs/libsigrok/libsigrok-9999.ebuild
@@ -3,24 +3,24 @@
EAPI="8"
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
-inherit python-r1 java-pkg-opt-2 udev xdg-utils
+inherit autotools python-r1 java-pkg-opt-2 udev xdg-utils
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
DESCRIPTION="Basic hardware drivers for logic analyzers and input/output file format support"
HOMEPAGE="https://sigrok.org/wiki/Libsigrok"
LICENSE="GPL-3"
-SLOT="0/9999"
-IUSE="bluetooth +cxx ftdi hidapi java nettle parport python serial static-libs test +udev usb"
+SLOT="0/4"
+IUSE="bluetooth +cxx ftdi hidapi java parport python serial static-libs test +udev usb"
REQUIRED_USE="java? ( cxx )
python? ( cxx ${PYTHON_REQUIRED_USE} )"
@@ -34,7 +34,6 @@ LIB_DEPEND="
cxx? ( dev-cpp/glibmm:2[static-libs(+)] )
ftdi? ( dev-embedded/libftdi:1[static-libs(+)] )
hidapi? ( >=dev-libs/hidapi-0.8.0 )
- nettle? ( dev-libs/nettle:=[static-libs(+)] )
parport? ( sys-libs/libieee1284[static-libs(+)] )
python? (
${PYTHON_DEPS}
@@ -65,6 +64,15 @@ DEPEND="${LIB_DEPEND//\[static-libs(+)]}
S="${WORKDIR}"/${P}
+PATCHES=(
+ # https://sigrok.org/bugzilla/show_bug.cgi?id=1527
+ "${FILESDIR}/${P}-swig-4.patch"
+ # https://sigrok.org/bugzilla/show_bug.cgi?id=1526
+ "${FILESDIR}/${P}-check-0.15.patch"
+ # https://bugs.gentoo.org/878395
+ "${FILESDIR}/${PN}-0.5.2-swig-4.1.patch"
+)
+
pkg_setup() {
use python && python_setup
java-pkg-opt-2_pkg_setup
@@ -75,7 +83,7 @@ src_unpack() {
}
sigrok_src_prepare() {
- [[ ${PV} == *9999* ]] && eautoreconf
+ eautoreconf
}
src_prepare() {
@@ -89,7 +97,6 @@ sigrok_src_configure() {
$(use_with bluetooth libbluez) \
$(use_with ftdi libftdi) \
$(use_with hidapi libhidapi) \
- $(use_with nettle libnettle) \
$(use_with parport libieee1284) \
$(use_with serial libserialport) \
$(use_with usb libusb) \